aboutsummaryrefslogtreecommitdiff
path: root/src/datacache/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/datacache/Makefile.am')
-rw-r--r--src/datacache/Makefile.am22
1 files changed, 11 insertions, 11 deletions
diff --git a/src/datacache/Makefile.am b/src/datacache/Makefile.am
index 1ae4744a8..def1eb58e 100644
--- a/src/datacache/Makefile.am
+++ b/src/datacache/Makefile.am
@@ -34,7 +34,7 @@ libgnunetdatacache_la_SOURCES = \
34 datacache.c 34 datacache.c
35libgnunetdatacache_la_LIBADD = \ 35libgnunetdatacache_la_LIBADD = \
36 $(top_builddir)/src/statistics/libgnunetstatistics.la \ 36 $(top_builddir)/src/statistics/libgnunetstatistics.la \
37 $(top_builddir)/src/util/libgnunetutil.la \ 37 $(top_builddir)/src/lib/util/libgnunetutil.la \
38 $(GN_LIBINTL) 38 $(GN_LIBINTL)
39libgnunetdatacache_la_LDFLAGS = \ 39libgnunetdatacache_la_LDFLAGS = \
40 $(GN_LIB_LDFLAGS) \ 40 $(GN_LIB_LDFLAGS) \
@@ -57,7 +57,7 @@ libgnunet_plugin_datacache_sqlite_la_SOURCES = \
57libgnunet_plugin_datacache_sqlite_la_LIBADD = \ 57libgnunet_plugin_datacache_sqlite_la_LIBADD = \
58 $(top_builddir)/src/statistics/libgnunetstatistics.la \ 58 $(top_builddir)/src/statistics/libgnunetstatistics.la \
59 $(top_builddir)/src/sq/libgnunetsq.la \ 59 $(top_builddir)/src/sq/libgnunetsq.la \
60 $(top_builddir)/src/util/libgnunetutil.la $(XLIBS) -lsqlite3 \ 60 $(top_builddir)/src/lib/util/libgnunetutil.la $(XLIBS) -lsqlite3 \
61 $(LTLIBINTL) 61 $(LTLIBINTL)
62libgnunet_plugin_datacache_sqlite_la_LDFLAGS = \ 62libgnunet_plugin_datacache_sqlite_la_LDFLAGS = \
63 $(GN_PLUGIN_LDFLAGS) 63 $(GN_PLUGIN_LDFLAGS)
@@ -66,7 +66,7 @@ libgnunet_plugin_datacache_heap_la_SOURCES = \
66 plugin_datacache_heap.c 66 plugin_datacache_heap.c
67libgnunet_plugin_datacache_heap_la_LIBADD = \ 67libgnunet_plugin_datacache_heap_la_LIBADD = \
68 $(top_builddir)/src/statistics/libgnunetstatistics.la \ 68 $(top_builddir)/src/statistics/libgnunetstatistics.la \
69 $(top_builddir)/src/util/libgnunetutil.la $(XLIBS) \ 69 $(top_builddir)/src/lib/util/libgnunetutil.la $(XLIBS) \
70 $(LTLIBINTL) 70 $(LTLIBINTL)
71libgnunet_plugin_datacache_heap_la_LDFLAGS = \ 71libgnunet_plugin_datacache_heap_la_LDFLAGS = \
72 $(GN_PLUGIN_LDFLAGS) 72 $(GN_PLUGIN_LDFLAGS)
@@ -76,7 +76,7 @@ libgnunet_plugin_datacache_postgres_la_SOURCES = \
76libgnunet_plugin_datacache_postgres_la_LIBADD = \ 76libgnunet_plugin_datacache_postgres_la_LIBADD = \
77 $(top_builddir)/src/pq/libgnunetpq.la \ 77 $(top_builddir)/src/pq/libgnunetpq.la \
78 $(top_builddir)/src/statistics/libgnunetstatistics.la \ 78 $(top_builddir)/src/statistics/libgnunetstatistics.la \
79 $(top_builddir)/src/util/libgnunetutil.la \ 79 $(top_builddir)/src/lib/util/libgnunetutil.la \
80 $(GN_PLUGIN_LDFLAGS) -lpq 80 $(GN_PLUGIN_LDFLAGS) -lpq
81libgnunet_plugin_datacache_postgres_la_CPPFLAGS = \ 81libgnunet_plugin_datacache_postgres_la_CPPFLAGS = \
82 $(POSTGRESQL_CPPFLAGS) $(AM_CPPFLAGS) 82 $(POSTGRESQL_CPPFLAGS) $(AM_CPPFLAGS)
@@ -86,7 +86,7 @@ libgnunet_plugin_datacache_postgres_la_LDFLAGS = \
86libgnunet_plugin_datacache_template_la_SOURCES = \ 86libgnunet_plugin_datacache_template_la_SOURCES = \
87 plugin_datacache_template.c 87 plugin_datacache_template.c
88libgnunet_plugin_datacache_template_la_LIBADD = \ 88libgnunet_plugin_datacache_template_la_LIBADD = \
89 $(top_builddir)/src/util/libgnunetutil.la $(XLIBS) \ 89 $(top_builddir)/src/lib/util/libgnunetutil.la $(XLIBS) \
90 $(LTLIBINTL) 90 $(LTLIBINTL)
91libgnunet_plugin_datacache_template_la_LDFLAGS = \ 91libgnunet_plugin_datacache_template_la_LDFLAGS = \
92 $(GN_PLUGIN_LDFLAGS) 92 $(GN_PLUGIN_LDFLAGS)
@@ -126,42 +126,42 @@ test_datacache_sqlite_SOURCES = \
126test_datacache_sqlite_LDADD = \ 126test_datacache_sqlite_LDADD = \
127 $(top_builddir)/src/testing/libgnunettesting.la \ 127 $(top_builddir)/src/testing/libgnunettesting.la \
128 libgnunetdatacache.la \ 128 libgnunetdatacache.la \
129 $(top_builddir)/src/util/libgnunetutil.la 129 $(top_builddir)/src/lib/util/libgnunetutil.la
130 130
131test_datacache_quota_sqlite_SOURCES = \ 131test_datacache_quota_sqlite_SOURCES = \
132 test_datacache_quota.c 132 test_datacache_quota.c
133test_datacache_quota_sqlite_LDADD = \ 133test_datacache_quota_sqlite_LDADD = \
134 $(top_builddir)/src/testing/libgnunettesting.la \ 134 $(top_builddir)/src/testing/libgnunettesting.la \
135 libgnunetdatacache.la \ 135 libgnunetdatacache.la \
136 $(top_builddir)/src/util/libgnunetutil.la 136 $(top_builddir)/src/lib/util/libgnunetutil.la
137 137
138test_datacache_heap_SOURCES = \ 138test_datacache_heap_SOURCES = \
139 test_datacache.c 139 test_datacache.c
140test_datacache_heap_LDADD = \ 140test_datacache_heap_LDADD = \
141 $(top_builddir)/src/testing/libgnunettesting.la \ 141 $(top_builddir)/src/testing/libgnunettesting.la \
142 libgnunetdatacache.la \ 142 libgnunetdatacache.la \
143 $(top_builddir)/src/util/libgnunetutil.la 143 $(top_builddir)/src/lib/util/libgnunetutil.la
144 144
145test_datacache_quota_heap_SOURCES = \ 145test_datacache_quota_heap_SOURCES = \
146 test_datacache_quota.c 146 test_datacache_quota.c
147test_datacache_quota_heap_LDADD = \ 147test_datacache_quota_heap_LDADD = \
148 $(top_builddir)/src/testing/libgnunettesting.la \ 148 $(top_builddir)/src/testing/libgnunettesting.la \
149 libgnunetdatacache.la \ 149 libgnunetdatacache.la \
150 $(top_builddir)/src/util/libgnunetutil.la 150 $(top_builddir)/src/lib/util/libgnunetutil.la
151 151
152test_datacache_postgres_SOURCES = \ 152test_datacache_postgres_SOURCES = \
153 test_datacache.c 153 test_datacache.c
154test_datacache_postgres_LDADD = \ 154test_datacache_postgres_LDADD = \
155 $(top_builddir)/src/testing/libgnunettesting.la \ 155 $(top_builddir)/src/testing/libgnunettesting.la \
156 libgnunetdatacache.la \ 156 libgnunetdatacache.la \
157 $(top_builddir)/src/util/libgnunetutil.la 157 $(top_builddir)/src/lib/util/libgnunetutil.la
158 158
159test_datacache_quota_postgres_SOURCES = \ 159test_datacache_quota_postgres_SOURCES = \
160 test_datacache_quota.c 160 test_datacache_quota.c
161test_datacache_quota_postgres_LDADD = \ 161test_datacache_quota_postgres_LDADD = \
162 $(top_builddir)/src/testing/libgnunettesting.la \ 162 $(top_builddir)/src/testing/libgnunettesting.la \
163 libgnunetdatacache.la \ 163 libgnunetdatacache.la \
164 $(top_builddir)/src/util/libgnunetutil.la 164 $(top_builddir)/src/lib/util/libgnunetutil.la
165 165
166EXTRA_DIST = \ 166EXTRA_DIST = \
167 test_datacache_data_sqlite.conf \ 167 test_datacache_data_sqlite.conf \