aboutsummaryrefslogtreecommitdiff
path: root/src/datacache/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/datacache/Makefile.am')
-rw-r--r--src/datacache/Makefile.am20
1 files changed, 16 insertions, 4 deletions
diff --git a/src/datacache/Makefile.am b/src/datacache/Makefile.am
index 5e3919820..921d88e5f 100644
--- a/src/datacache/Makefile.am
+++ b/src/datacache/Makefile.am
@@ -81,24 +81,36 @@ libgnunet_plugin_datacache_template_la_LDFLAGS = \
81 81
82 82
83if HAVE_SQLITE 83if HAVE_SQLITE
84if HAVE_BENCHMARKS
85 SQLITE_BENCHMARKS = \
86 perf_datacache_postgres
87endif
84SQLITE_TESTS = \ 88SQLITE_TESTS = \
85 test_datacache_sqlite \ 89 test_datacache_sqlite \
86 test_datacache_quota_sqlite \ 90 test_datacache_quota_sqlite \
87 perf_datacache_sqlite 91 $(SQLITE_BENCHMARKS)
88endif 92endif
89 93
90if HAVE_MYSQL 94if HAVE_MYSQL
95if HAVE_BENCHMARKS
96 MYSQL_BENCHMARKS = \
97 perf_datacache_postgres
98endif
91MYSQL_TESTS = \ 99MYSQL_TESTS = \
92 test_datacache_mysql \ 100 test_datacache_mysql \
93 test_datacache_quota_mysql \ 101 test_datacache_quota_mysql \
94 perf_datacache_mysql 102 $(MYSQL_BENCHMARKS)
95endif 103endif
96 104
97if HAVE_POSTGRES 105if HAVE_POSTGRES
106if HAVE_BENCHMARKS
107 POSTGRES_BENCHMARKS = \
108 perf_datacache_postgres
109endif
98POSTGRES_TESTS = \ 110POSTGRES_TESTS = \
99 test_datacache_postgres \ 111 test_datacache_postgres \
100 test_datacache_quota_postgres \ 112 test_datacache_quota_postgres \
101 perf_datacache_postgres 113 $(POSTGRES_BENCHMARKS)
102endif 114endif
103 115
104check_PROGRAMS = \ 116check_PROGRAMS = \
@@ -106,7 +118,7 @@ check_PROGRAMS = \
106 $(MYSQL_TESTS) \ 118 $(MYSQL_TESTS) \
107 $(POSTGRES_TESTS) 119 $(POSTGRES_TESTS)
108 120
109if !DISABLE_TEST_RUN 121if ENABLE_TEST_RUN
110TESTS = $(check_PROGRAMS) 122TESTS = $(check_PROGRAMS)
111endif 123endif
112 124