aboutsummaryrefslogtreecommitdiff
path: root/src/datacache/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/datacache/meson.build')
-rw-r--r--src/datacache/meson.build122
1 files changed, 121 insertions, 1 deletions
diff --git a/src/datacache/meson.build b/src/datacache/meson.build
index bde9f8621..775f2ee61 100644
--- a/src/datacache/meson.build
+++ b/src/datacache/meson.build
@@ -37,6 +37,7 @@ shared_module('gnunet_plugin_datacache_sqlite',
37 include_directories: [incdir, configuration_inc], 37 include_directories: [incdir, configuration_inc],
38 install: true, 38 install: true,
39 install_dir: get_option('libdir')/'gnunet') 39 install_dir: get_option('libdir')/'gnunet')
40
40shared_module('gnunet_plugin_datacache_heap', 41shared_module('gnunet_plugin_datacache_heap',
41 ['plugin_datacache_heap.c'], 42 ['plugin_datacache_heap.c'],
42 dependencies: [libgnunetutil_dep, 43 dependencies: [libgnunetutil_dep,
@@ -45,7 +46,6 @@ shared_module('gnunet_plugin_datacache_heap',
45 install: true, 46 install: true,
46 install_dir: get_option('libdir')/'gnunet') 47 install_dir: get_option('libdir')/'gnunet')
47 48
48
49if pq_dep.found() 49if pq_dep.found()
50 shared_module('gnunet_plugin_datacache_postgres', 50 shared_module('gnunet_plugin_datacache_postgres',
51 ['plugin_datacache_postgres.c'], 51 ['plugin_datacache_postgres.c'],
@@ -57,3 +57,123 @@ if pq_dep.found()
57 install: true, 57 install: true,
58 install_dir: get_option('libdir')/'gnunet') 58 install_dir: get_option('libdir')/'gnunet')
59endif 59endif
60
61testdc_sqlite = executable ('test_datacache_sqlite',
62 ['test_datacache.c'],
63 dependencies: [
64 libgnunetdatacache_dep,
65 libgnunetutil_dep,
66 libgnunettesting_dep
67 ],
68 include_directories: [incdir, configuration_inc],
69 install: false)
70
71testdc_quota_sqlite = executable ('test_datacache_quota_sqlite',
72 ['test_datacache_quota.c'],
73 dependencies: [
74 libgnunetdatacache_dep,
75 libgnunetutil_dep,
76 libgnunettesting_dep
77 ],
78 include_directories: [incdir, configuration_inc],
79 install: false)
80
81#testdc_perf_sqlite = executable ('perf_datacache_sqlite',
82# ['perf_datacache.c'],
83# dependencies: [
84# libgnunetdatacache_dep,
85# libgnunetutil_dep,
86# libgnunettesting_dep
87# ],
88# include_directories: [incdir, configuration_inc],
89# install: false)
90
91testdc_heap = executable ('test_datacache_heap',
92 ['test_datacache.c'],
93 dependencies: [
94 libgnunetdatacache_dep,
95 libgnunetutil_dep,
96 libgnunettesting_dep
97 ],
98 include_directories: [incdir, configuration_inc],
99 install: false)
100
101testdc_quota_heap = executable ('test_datacache_quota_heap',
102 ['test_datacache_quota.c'],
103 dependencies: [
104 libgnunetdatacache_dep,
105 libgnunetutil_dep,
106 libgnunettesting_dep
107 ],
108 include_directories: [incdir, configuration_inc],
109 install: false)
110
111#testdc_perf_heap = executable ('perf_datacache_heap',
112# ['perf_datacache.c'],
113# dependencies: [
114# libgnunetdatacache_dep,
115# libgnunetutil_dep,
116# libgnunettesting_dep
117# ],
118# include_directories: [incdir, configuration_inc],
119# install: false)
120
121testdc_pq = executable ('test_datacache_postgres',
122 ['test_datacache.c'],
123 dependencies: [
124 libgnunetdatacache_dep,
125 libgnunetutil_dep,
126 libgnunettesting_dep
127 ],
128 include_directories: [incdir, configuration_inc],
129 install: false)
130
131testdc_quota_pq = executable ('test_datacache_quota_postgres',
132 ['test_datacache_quota.c'],
133 dependencies: [
134 libgnunetdatacache_dep,
135 libgnunetutil_dep,
136 libgnunettesting_dep
137 ],
138 include_directories: [incdir, configuration_inc],
139 install: false)
140
141#testdc_perf_pq = executable ('perf_datacache_postgres',
142# ['perf_datacache.c'],
143# dependencies: [
144# libgnunetdatacache_dep,
145# libgnunetutil_dep,
146# libgnunettesting_dep
147# ],
148# include_directories: [incdir, configuration_inc],
149# install: false)
150
151configure_file(input : 'test_datacache_data_sqlite.conf',
152 output : 'test_datacache_data_sqlite.conf',
153 copy: true)
154configure_file(input : 'test_datacache_data_heap.conf',
155 output : 'test_datacache_data_heap.conf',
156 copy: true)
157configure_file(input : 'test_datacache_data_postgres.conf',
158 output : 'test_datacache_data_postgres.conf',
159 copy: true)
160
161test('test_datacache_sqlite', testdc_sqlite,
162 suite: 'datacache', workdir: meson.current_build_dir())
163test('test_datacache_quota_sqlite', testdc_quota_sqlite,
164 suite: 'datacache', workdir: meson.current_build_dir())
165#test('perf_datacache_sqlite', testdc_perf_sqlite,
166# suite: 'datacache', workdir: meson.current_build_dir())
167test('test_datacache_heap', testdc_heap,
168 suite: 'datacache', workdir: meson.current_build_dir())
169test('test_datacache_quota_heap', testdc_quota_heap,
170 suite: 'datacache', workdir: meson.current_build_dir())
171#test('perf_datacache_heap', testdc_perf_heap,
172# suite: 'datacache', workdir: meson.current_build_dir())
173test('test_datacache_postgres', testdc_pq,
174 suite: 'datacache', workdir: meson.current_build_dir())
175test('test_datacache_quota_postgres', testdc_quota_pq,
176 suite: 'datacache', workdir: meson.current_build_dir())
177#test('perf_datacache_postgres', testdc_perf_pq,
178# suite: 'datacache', workdir: meson.current_build_dir())
179