aboutsummaryrefslogtreecommitdiff
path: root/src/datacache/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/datacache/meson.build')
-rw-r--r--src/datacache/meson.build36
1 files changed, 0 insertions, 36 deletions
diff --git a/src/datacache/meson.build b/src/datacache/meson.build
index 775f2ee61..91bf1a02d 100644
--- a/src/datacache/meson.build
+++ b/src/datacache/meson.build
@@ -78,16 +78,6 @@ testdc_quota_sqlite = executable ('test_datacache_quota_sqlite',
78 include_directories: [incdir, configuration_inc], 78 include_directories: [incdir, configuration_inc],
79 install: false) 79 install: false)
80 80
81#testdc_perf_sqlite = executable ('perf_datacache_sqlite',
82# ['perf_datacache.c'],
83# dependencies: [
84# libgnunetdatacache_dep,
85# libgnunetutil_dep,
86# libgnunettesting_dep
87# ],
88# include_directories: [incdir, configuration_inc],
89# install: false)
90
91testdc_heap = executable ('test_datacache_heap', 81testdc_heap = executable ('test_datacache_heap',
92 ['test_datacache.c'], 82 ['test_datacache.c'],
93 dependencies: [ 83 dependencies: [
@@ -108,15 +98,6 @@ testdc_quota_heap = executable ('test_datacache_quota_heap',
108 include_directories: [incdir, configuration_inc], 98 include_directories: [incdir, configuration_inc],
109 install: false) 99 install: false)
110 100
111#testdc_perf_heap = executable ('perf_datacache_heap',
112# ['perf_datacache.c'],
113# dependencies: [
114# libgnunetdatacache_dep,
115# libgnunetutil_dep,
116# libgnunettesting_dep
117# ],
118# include_directories: [incdir, configuration_inc],
119# install: false)
120 101
121testdc_pq = executable ('test_datacache_postgres', 102testdc_pq = executable ('test_datacache_postgres',
122 ['test_datacache.c'], 103 ['test_datacache.c'],
@@ -138,16 +119,6 @@ testdc_quota_pq = executable ('test_datacache_quota_postgres',
138 include_directories: [incdir, configuration_inc], 119 include_directories: [incdir, configuration_inc],
139 install: false) 120 install: false)
140 121
141#testdc_perf_pq = executable ('perf_datacache_postgres',
142# ['perf_datacache.c'],
143# dependencies: [
144# libgnunetdatacache_dep,
145# libgnunetutil_dep,
146# libgnunettesting_dep
147# ],
148# include_directories: [incdir, configuration_inc],
149# install: false)
150
151configure_file(input : 'test_datacache_data_sqlite.conf', 122configure_file(input : 'test_datacache_data_sqlite.conf',
152 output : 'test_datacache_data_sqlite.conf', 123 output : 'test_datacache_data_sqlite.conf',
153 copy: true) 124 copy: true)
@@ -162,18 +133,11 @@ test('test_datacache_sqlite', testdc_sqlite,
162 suite: 'datacache', workdir: meson.current_build_dir()) 133 suite: 'datacache', workdir: meson.current_build_dir())
163test('test_datacache_quota_sqlite', testdc_quota_sqlite, 134test('test_datacache_quota_sqlite', testdc_quota_sqlite,
164 suite: 'datacache', workdir: meson.current_build_dir()) 135 suite: 'datacache', workdir: meson.current_build_dir())
165#test('perf_datacache_sqlite', testdc_perf_sqlite,
166# suite: 'datacache', workdir: meson.current_build_dir())
167test('test_datacache_heap', testdc_heap, 136test('test_datacache_heap', testdc_heap,
168 suite: 'datacache', workdir: meson.current_build_dir()) 137 suite: 'datacache', workdir: meson.current_build_dir())
169test('test_datacache_quota_heap', testdc_quota_heap, 138test('test_datacache_quota_heap', testdc_quota_heap,
170 suite: 'datacache', workdir: meson.current_build_dir()) 139 suite: 'datacache', workdir: meson.current_build_dir())
171#test('perf_datacache_heap', testdc_perf_heap,
172# suite: 'datacache', workdir: meson.current_build_dir())
173test('test_datacache_postgres', testdc_pq, 140test('test_datacache_postgres', testdc_pq,
174 suite: 'datacache', workdir: meson.current_build_dir()) 141 suite: 'datacache', workdir: meson.current_build_dir())
175test('test_datacache_quota_postgres', testdc_quota_pq, 142test('test_datacache_quota_postgres', testdc_quota_pq,
176 suite: 'datacache', workdir: meson.current_build_dir()) 143 suite: 'datacache', workdir: meson.current_build_dir())
177#test('perf_datacache_postgres', testdc_perf_pq,
178# suite: 'datacache', workdir: meson.current_build_dir())
179