aboutsummaryrefslogtreecommitdiff
path: root/src/datastore/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/datastore/meson.build')
-rw-r--r--src/datastore/meson.build81
1 files changed, 81 insertions, 0 deletions
diff --git a/src/datastore/meson.build b/src/datastore/meson.build
new file mode 100644
index 000000000..2f412e183
--- /dev/null
+++ b/src/datastore/meson.build
@@ -0,0 +1,81 @@
1libgnunetdatastore_src = ['datastore_api.c']
2
3gnunetservicedatastore_src = ['gnunet-service-datastore.c']
4
5configure_file(input : 'datastore.conf.in',
6 output : 'datastore.conf',
7 configuration : cdata,
8 install: true,
9 install_dir: pkgcfgdir)
10
11install_data ('datastore-0001.sql',
12 'datastore-drop.sql',
13 install_dir: get_option('datadir')/'gnunet'/'sql')
14
15if get_option('monolith')
16 foreach p : libgnunetdatastore_src + gnunetservicedatastore_src
17 gnunet_src += 'datastore/' + p
18 endforeach
19endif
20libgnunetdatastore = library('gnunetdatastore',
21 libgnunetdatastore_src,
22 soversion: '1',
23 version: '1.0.0',
24 dependencies: [libgnunetutil_dep,
25 libgnunetstatistics_dep,
26 libgnunetdatacache_dep],
27 include_directories: [incdir, configuration_inc],
28 install: true,
29 install_dir: get_option('libdir'))
30libgnunetdatastore_dep = declare_dependency(link_with : libgnunetdatastore)
31pkg.generate(libgnunetdatastore, url: 'https://www.gnunet.org',
32 description : 'Management API for the datastore for persistent storage to disk')
33
34shared_module('gnunet_plugin_datastore_sqlite',
35 ['plugin_datastore_sqlite.c'],
36 dependencies: [libgnunetutil_dep,
37 libgnunetdatastore_dep,
38 sqlite_dep,
39 libgnunetsq_dep],
40 include_directories: [incdir, configuration_inc],
41 install: true,
42 install_dir: get_option('libdir')/'gnunet')
43shared_module('gnunet_plugin_datastore_heap',
44 ['plugin_datastore_heap.c'],
45 dependencies: [libgnunetutil_dep,
46 libgnunetdatacache_dep],
47 include_directories: [incdir, configuration_inc],
48 install: true,
49 install_dir: get_option('libdir')/'gnunet')
50
51if pq_dep.found()
52 shared_module('gnunet_plugin_datastore_postgres',
53 ['plugin_datastore_postgres.c'],
54 dependencies: [libgnunetutil_dep,
55 libgnunetdatastore_dep,
56 pq_dep,
57 libgnunetpq_dep],
58 include_directories: [incdir, configuration_inc],
59 install: true,
60 install_dir: get_option('libdir')/'gnunet')
61endif
62
63executable ('gnunet-datastore',
64 ['gnunet-datastore.c'],
65 dependencies: [libgnunetdatastore_dep,
66 libgnunetutil_dep,
67 libgnunetstatistics_dep,
68 libgnunetdatacache_dep],
69 include_directories: [incdir, configuration_inc],
70 install: true,
71 install_dir: get_option('bindir'))
72executable ('gnunet-service-datastore',
73 gnunetservicedatastore_src,
74 dependencies: [libgnunetdatastore_dep,
75 libgnunetutil_dep,
76 libgnunetstatistics_dep,
77 libgnunetdatacache_dep],
78 include_directories: [incdir, configuration_inc],
79 install: true,
80 install_dir: get_option('libdir')/'gnunet'/'libexec')
81