aboutsummaryrefslogtreecommitdiff
path: root/src/datastore/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/datastore/meson.build')
-rw-r--r--src/datastore/meson.build25
1 files changed, 25 insertions, 0 deletions
diff --git a/src/datastore/meson.build b/src/datastore/meson.build
new file mode 100644
index 000000000..e98e58dcf
--- /dev/null
+++ b/src/datastore/meson.build
@@ -0,0 +1,25 @@
1libgnunetdatastore_src = ['datastore_api.c']
2
3gnunetservicedatastore_src = ['gnunet-service-datastore.c']
4
5
6if gnunet_monolith == false
7 libgnunetdatastore = library('gnunetdatastore',
8 libgnunetdatastore_src,
9 dependencies: [libgnunetutil_dep,
10 libgnunetstatistics_dep,
11 libgnunetdatacache_dep],
12 include_directories: [incdir, configuration_inc])
13 libgnunetdatastore_dep = declare_dependency(link_with : libgnunetdatastore)
14 executable ('gnunet-service-datastore',
15 gnunetservicedatastore_src,
16 dependencies: [libgnunetdatastore_dep,
17 libgnunetutil_dep,
18 libgnunetstatistics_dep,
19 libgnunetdatacache_dep],
20 include_directories: [incdir, configuration_inc])
21else
22 foreach p : libgnunetdatastore_src + gnunetservicedatastore_src
23 gnunet_src += 'datastore/' + p
24 endforeach
25endif