aboutsummaryrefslogtreecommitdiff
path: root/src/dht/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/dht/Makefile.am')
-rw-r--r--src/dht/Makefile.am222
1 files changed, 0 insertions, 222 deletions
diff --git a/src/dht/Makefile.am b/src/dht/Makefile.am
deleted file mode 100644
index be48fab02..000000000
--- a/src/dht/Makefile.am
+++ /dev/null
@@ -1,222 +0,0 @@
1# This Makefile.am is in the public domain
2AM_CPPFLAGS = -I$(top_srcdir)/src/include
3
4plugindir = $(libdir)/gnunet
5
6pkgcfgdir= $(pkgdatadir)/config.d/
7
8libexecdir= $(pkglibdir)/libexec/
9
10pkgcfg_DATA = \
11 dht.conf
12
13if USE_COVERAGE
14 AM_CFLAGS = --coverage -O0
15 XLIB = -lgcov
16endif
17
18lib_LTLIBRARIES = \
19 libgnunetdht.la
20
21libgnunetdht_la_SOURCES = \
22 dht_api.c dht.h
23libgnunetdht_la_LIBADD = \
24 $(top_builddir)/src/util/libgnunetutil.la \
25 $(XLIB) \
26 $(LTLIBINTL)
27libgnunetdht_la_LDFLAGS = \
28 $(GN_LIB_LDFLAGS) \
29 -version-info 3:0:0
30
31
32plugin_LTLIBRARIES = \
33 libgnunet_plugin_block_dht.la
34
35libgnunet_plugin_block_dht_la_SOURCES = \
36 plugin_block_dht.c
37libgnunet_plugin_block_dht_la_LIBADD = \
38 $(top_builddir)/src/hello/libgnunethello.la \
39 $(top_builddir)/src/block/libgnunetblock.la \
40 $(top_builddir)/src/block/libgnunetblockgroup.la \
41 $(top_builddir)/src/util/libgnunetutil.la \
42 $(LTLIBINTL)
43libgnunet_plugin_block_dht_la_LDFLAGS = \
44 $(GN_PLUGIN_LDFLAGS)
45
46
47libexec_PROGRAMS = \
48 gnunet-service-dht
49
50bin_PROGRAMS = \
51 gnunet-dht-monitor \
52 gnunet-dht-get \
53 gnunet-dht-put
54
55noinst_PROGRAMS = \
56 gnunet-dht-profiler
57
58gnunet_service_dht_SOURCES = \
59 gnunet-service-dht.c gnunet-service-dht.h \
60 gnunet-service-dht_datacache.c gnunet-service-dht_datacache.h \
61 gnunet-service-dht_hello.c gnunet-service-dht_hello.h \
62 gnunet-service-dht_nse.c gnunet-service-dht_nse.h \
63 gnunet-service-dht_neighbours.c gnunet-service-dht_neighbours.h \
64 gnunet-service-dht_routing.c gnunet-service-dht_routing.h
65gnunet_service_dht_LDADD = \
66 libgnunetdht.la \
67 $(top_builddir)/src/statistics/libgnunetstatistics.la \
68 $(top_builddir)/src/core/libgnunetcore.la \
69 $(top_builddir)/src/nse/libgnunetnse.la \
70 $(top_builddir)/src/ats/libgnunetats.la \
71 $(top_builddir)/src/transport/libgnunettransport.la \
72 $(top_builddir)/src/peerinfo/libgnunetpeerinfo.la \
73 $(top_builddir)/src/hello/libgnunethello.la \
74 $(top_builddir)/src/block/libgnunetblock.la \
75 $(top_builddir)/src/datacache/libgnunetdatacache.la \
76 $(top_builddir)/src/util/libgnunetutil.la \
77 -lm
78gnunet_service_dht_LDFLAGS = \
79 $(GN_LIBINTL)
80
81gnunet_dht_get_SOURCES = \
82 gnunet-dht-get.c
83gnunet_dht_get_LDADD = \
84 libgnunetdht.la \
85 $(top_builddir)/src/core/libgnunetcore.la \
86 $(top_builddir)/src/util/libgnunetutil.la
87gnunet_dht_get_LDFLAGS = \
88 $(GN_LIBINTL)
89
90gnunet_dht_put_SOURCES = \
91 gnunet-dht-put.c
92gnunet_dht_put_LDADD = \
93 libgnunetdht.la \
94 $(top_builddir)/src/core/libgnunetcore.la \
95 $(top_builddir)/src/util/libgnunetutil.la
96gnunet_dht_put_LDFLAGS = \
97 $(GN_LIBINTL)
98
99gnunet_dht_monitor_SOURCES = \
100 gnunet-dht-monitor.c
101gnunet_dht_monitor_LDADD = \
102 libgnunetdht.la \
103 $(top_builddir)/src/core/libgnunetcore.la \
104 $(top_builddir)/src/util/libgnunetutil.la
105gnunet_dht_monitor_LDFLAGS = \
106 $(GN_LIBINTL)
107
108gnunet_dht_profiler_SOURCES = \
109 gnunet_dht_profiler.c
110gnunet_dht_profiler_LDADD = \
111 libgnunetdht.la \
112 $(top_builddir)/src/core/libgnunetcore.la \
113 $(top_builddir)/src/util/libgnunetutil.la \
114 $(top_builddir)/src/testing/libgnunettesting.la \
115 $(top_builddir)/src/testbed/libgnunettestbed.la
116gnunet_dht_profiler_LDFLAGS = \
117 $(GN_LIBINTL)
118
119noinst_LIBRARIES = libgnunetdhttest.a
120
121libgnunetdhttest_a_SOURCES = \
122 dht_test_lib.c dht_test_lib.h
123libgnunetdhttest_a_LIBADD = \
124 $(top_builddir)/src/util/libgnunetutil.la \
125 $(top_builddir)/src/testbed/libgnunettestbed.la \
126 libgnunetdht.la
127
128check_PROGRAMS = \
129 test_dht_api \
130 test_dht_twopeer \
131 test_dht_multipeer \
132 test_dht_line \
133 test_dht_2dtorus \
134 test_dht_monitor
135
136if HAVE_EXPERIMENTAL
137# These tests still do not work as testbed does
138# not support the respective topology op
139 NEW_TESTS = test_dht_2dtorus test_dht_multipeer
140endif
141
142if ENABLE_TEST_RUN
143AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME;
144TESTS = test_dht_api $(check_SCRIPTS) \
145 test_dht_twopeer \
146 test_dht_line \
147 test_dht_monitor \
148 $(NEW_TESTS)
149endif
150
151test_dht_api_SOURCES = \
152 test_dht_api.c
153test_dht_api_LDADD = \
154 $(top_builddir)/src/util/libgnunetutil.la \
155 $(top_builddir)/src/testing/libgnunettesting.la \
156 $(top_builddir)/src/hello/libgnunethello.la \
157 libgnunetdht.la
158
159test_dht_twopeer_SOURCES = \
160 test_dht_topo.c
161test_dht_twopeer_LDADD = \
162 libgnunetdhttest.a \
163 $(top_builddir)/src/util/libgnunetutil.la \
164 libgnunetdhttest.a \
165 $(top_builddir)/src/testbed/libgnunettestbed.la \
166 libgnunetdht.la
167
168test_dht_2dtorus_SOURCES = \
169 test_dht_topo.c
170test_dht_2dtorus_LDADD = \
171 libgnunetdhttest.a \
172 $(top_builddir)/src/util/libgnunetutil.la \
173 $(top_builddir)/src/testbed/libgnunettestbed.la \
174 libgnunetdht.la
175
176test_dht_line_SOURCES = \
177 test_dht_topo.c
178test_dht_line_LDADD = \
179 libgnunetdhttest.a \
180 $(top_builddir)/src/util/libgnunetutil.la \
181 $(top_builddir)/src/testbed/libgnunettestbed.la \
182 libgnunetdht.la
183
184test_dht_multipeer_SOURCES = \
185 test_dht_topo.c
186test_dht_multipeer_LDADD = \
187 libgnunetdhttest.a \
188 $(top_builddir)/src/util/libgnunetutil.la \
189 $(top_builddir)/src/statistics/libgnunetstatistics.la \
190 $(top_builddir)/src/testbed/libgnunettestbed.la \
191 libgnunetdht.la
192
193test_dht_monitor_SOURCES = \
194 test_dht_monitor.c
195test_dht_monitor_LDADD = \
196 libgnunetdhttest.a \
197 $(top_builddir)/src/util/libgnunetutil.la \
198 $(top_builddir)/src/testbed/libgnunettestbed.la \
199 libgnunetdht.la
200
201EXTRA_DIST = \
202 $(check_SCRIPTS) \
203 gnunet-service-dht_clients.c \
204 test_dht_api_data.conf \
205 test_dht_api_peer1.conf \
206 test_dht_monitor.conf \
207 test_dht_multipeer.conf \
208 test_dht_2dtorus.conf \
209 test_dht_line.conf \
210 test_dht_tools.conf \
211 test_dht_tools.py.in \
212 test_dht_multipeer_topology.dat
213
214if HAVE_PYTHON
215check_SCRIPTS = \
216 test_dht_tools.py
217endif
218
219SUFFIXES = .py.in .py
220.py.in.py:
221 $(AWK) -v bdir="$(bindir)" -v py="$(PYTHON)" -v awkay="$(AWK_BINARY)" -v pfx="$(prefix)" -v prl="$(PERL)" -v sysconfdirectory="$(sysconfdir)" -v pkgdatadirectory="$(pkgdatadir)" -f $(top_srcdir)/bin/dosubst.awk < $(srcdir)/$< > $@
222 chmod +x $@