aboutsummaryrefslogtreecommitdiff
path: root/src/dht/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/dht/Makefile.am')
-rw-r--r--src/dht/Makefile.am221
1 files changed, 0 insertions, 221 deletions
diff --git a/src/dht/Makefile.am b/src/dht/Makefile.am
deleted file mode 100644
index 69e34000c..000000000
--- a/src/dht/Makefile.am
+++ /dev/null
@@ -1,221 +0,0 @@
1# This Makefile.am is in the public domain
2AM_CPPFLAGS = -I$(top_srcdir)/src/include
3
4plugindir = $(libdir)/gnunet
5
6pkgcfgdir= $(pkgdatadir)/config.d/
7
8libexecdir= $(pkglibdir)/libexec/
9
10pkgcfg_DATA = \
11 dht.conf
12
13if USE_COVERAGE
14 AM_CFLAGS = --coverage -O0
15 XLIB = -lgcov
16endif
17
18lib_LTLIBRARIES = \
19 libgnunetdht.la
20
21libgnunetdht_la_SOURCES = \
22 dht_api.c dht.h
23libgnunetdht_la_LIBADD = \
24 $(top_builddir)/src/util/libgnunetutil.la \
25 $(XLIB) \
26 $(LTLIBINTL)
27libgnunetdht_la_LDFLAGS = \
28 $(GN_LIB_LDFLAGS) \
29 -version-info 3:0:0
30
31
32plugin_LTLIBRARIES = \
33 libgnunet_plugin_block_dht.la
34
35libgnunet_plugin_block_dht_la_SOURCES = \
36 plugin_block_dht.c
37libgnunet_plugin_block_dht_la_LIBADD = \
38 $(top_builddir)/src/hello/libgnunethello.la \
39 $(top_builddir)/src/block/libgnunetblock.la \
40 $(top_builddir)/src/block/libgnunetblockgroup.la \
41 $(top_builddir)/src/util/libgnunetutil.la \
42 $(LTLIBINTL)
43libgnunet_plugin_block_dht_la_LDFLAGS = \
44 $(GN_PLUGIN_LDFLAGS)
45
46
47libexec_PROGRAMS = \
48 gnunet-service-dht
49
50bin_PROGRAMS = \
51 gnunet-dht-monitor \
52 gnunet-dht-get \
53 gnunet-dht-put
54
55noinst_PROGRAMS = \
56 gnunet-dht-profiler
57
58gnunet_service_dht_SOURCES = \
59 gnunet-service-dht.c gnunet-service-dht.h \
60 gnunet-service-dht_datacache.c gnunet-service-dht_datacache.h \
61 gnunet-service-dht_hello.c gnunet-service-dht_hello.h \
62 gnunet-service-dht_nse.c gnunet-service-dht_nse.h \
63 gnunet-service-dht_neighbours.c gnunet-service-dht_neighbours.h \
64 gnunet-service-dht_routing.c gnunet-service-dht_routing.h
65gnunet_service_dht_LDADD = \
66 $(top_builddir)/src/statistics/libgnunetstatistics.la \
67 $(top_builddir)/src/core/libgnunetcore.la \
68 $(top_builddir)/src/nse/libgnunetnse.la \
69 $(top_builddir)/src/ats/libgnunetats.la \
70 $(top_builddir)/src/transport/libgnunettransport.la \
71 $(top_builddir)/src/peerinfo/libgnunetpeerinfo.la \
72 $(top_builddir)/src/hello/libgnunethello.la \
73 $(top_builddir)/src/block/libgnunetblock.la \
74 $(top_builddir)/src/datacache/libgnunetdatacache.la \
75 $(top_builddir)/src/util/libgnunetutil.la \
76 -lm
77gnunet_service_dht_LDFLAGS = \
78 $(GN_LIBINTL)
79
80gnunet_dht_get_SOURCES = \
81 gnunet-dht-get.c
82gnunet_dht_get_LDADD = \
83 libgnunetdht.la \
84 $(top_builddir)/src/core/libgnunetcore.la \
85 $(top_builddir)/src/util/libgnunetutil.la
86gnunet_dht_get_LDFLAGS = \
87 $(GN_LIBINTL)
88
89gnunet_dht_put_SOURCES = \
90 gnunet-dht-put.c
91gnunet_dht_put_LDADD = \
92 libgnunetdht.la \
93 $(top_builddir)/src/core/libgnunetcore.la \
94 $(top_builddir)/src/util/libgnunetutil.la
95gnunet_dht_put_LDFLAGS = \
96 $(GN_LIBINTL)
97
98gnunet_dht_monitor_SOURCES = \
99 gnunet-dht-monitor.c
100gnunet_dht_monitor_LDADD = \
101 libgnunetdht.la \
102 $(top_builddir)/src/core/libgnunetcore.la \
103 $(top_builddir)/src/util/libgnunetutil.la
104gnunet_dht_monitor_LDFLAGS = \
105 $(GN_LIBINTL)
106
107gnunet_dht_profiler_SOURCES = \
108 gnunet_dht_profiler.c
109gnunet_dht_profiler_LDADD = \
110 libgnunetdht.la \
111 $(top_builddir)/src/core/libgnunetcore.la \
112 $(top_builddir)/src/util/libgnunetutil.la \
113 $(top_builddir)/src/testing/libgnunettesting.la \
114 $(top_builddir)/src/testbed/libgnunettestbed.la
115gnunet_dht_profiler_LDFLAGS = \
116 $(GN_LIBINTL)
117
118noinst_LIBRARIES = libgnunetdhttest.a
119
120libgnunetdhttest_a_SOURCES = \
121 dht_test_lib.c dht_test_lib.h
122libgnunetdhttest_a_LIBADD = \
123 $(top_builddir)/src/util/libgnunetutil.la \
124 $(top_builddir)/src/testbed/libgnunettestbed.la \
125 libgnunetdht.la
126
127check_PROGRAMS = \
128 test_dht_api \
129 test_dht_twopeer \
130 test_dht_multipeer \
131 test_dht_line \
132 test_dht_2dtorus \
133 test_dht_monitor
134
135if HAVE_EXPERIMENTAL
136# These tests still do not work as testbed does
137# not support the respective topology op
138 NEW_TESTS = test_dht_2dtorus test_dht_multipeer
139endif
140
141if ENABLE_TEST_RUN
142AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME;
143TESTS = test_dht_api $(check_SCRIPTS) \
144 test_dht_twopeer \
145 test_dht_line \
146 test_dht_monitor \
147 $(NEW_TESTS)
148endif
149
150test_dht_api_SOURCES = \
151 test_dht_api.c
152test_dht_api_LDADD = \
153 $(top_builddir)/src/util/libgnunetutil.la \
154 $(top_builddir)/src/testing/libgnunettesting.la \
155 $(top_builddir)/src/hello/libgnunethello.la \
156 libgnunetdht.la
157
158test_dht_twopeer_SOURCES = \
159 test_dht_topo.c
160test_dht_twopeer_LDADD = \
161 libgnunetdhttest.a \
162 $(top_builddir)/src/util/libgnunetutil.la \
163 libgnunetdhttest.a \
164 $(top_builddir)/src/testbed/libgnunettestbed.la \
165 libgnunetdht.la
166
167test_dht_2dtorus_SOURCES = \
168 test_dht_topo.c
169test_dht_2dtorus_LDADD = \
170 libgnunetdhttest.a \
171 $(top_builddir)/src/util/libgnunetutil.la \
172 $(top_builddir)/src/testbed/libgnunettestbed.la \
173 libgnunetdht.la
174
175test_dht_line_SOURCES = \
176 test_dht_topo.c
177test_dht_line_LDADD = \
178 libgnunetdhttest.a \
179 $(top_builddir)/src/util/libgnunetutil.la \
180 $(top_builddir)/src/testbed/libgnunettestbed.la \
181 libgnunetdht.la
182
183test_dht_multipeer_SOURCES = \
184 test_dht_topo.c
185test_dht_multipeer_LDADD = \
186 libgnunetdhttest.a \
187 $(top_builddir)/src/util/libgnunetutil.la \
188 $(top_builddir)/src/statistics/libgnunetstatistics.la \
189 $(top_builddir)/src/testbed/libgnunettestbed.la \
190 libgnunetdht.la
191
192test_dht_monitor_SOURCES = \
193 test_dht_monitor.c
194test_dht_monitor_LDADD = \
195 libgnunetdhttest.a \
196 $(top_builddir)/src/util/libgnunetutil.la \
197 $(top_builddir)/src/testbed/libgnunettestbed.la \
198 libgnunetdht.la
199
200EXTRA_DIST = \
201 $(check_SCRIPTS) \
202 gnunet-service-dht_clients.c \
203 test_dht_api_data.conf \
204 test_dht_api_peer1.conf \
205 test_dht_monitor.conf \
206 test_dht_multipeer.conf \
207 test_dht_2dtorus.conf \
208 test_dht_line.conf \
209 test_dht_tools.conf \
210 test_dht_tools.py.in \
211 test_dht_multipeer_topology.dat
212
213if HAVE_PYTHON
214check_SCRIPTS = \
215 test_dht_tools.py
216endif
217
218SUFFIXES = .py.in .py
219.py.in.py:
220 $(AWK) -v bdir="$(bindir)" -v py="$(PYTHON)" -v awkay="$(AWK_BINARY)" -v pfx="$(prefix)" -v prl="$(PERL)" -v sysconfdirectory="$(sysconfdir)" -v pkgdatadirectory="$(pkgdatadir)" -f $(top_srcdir)/bin/dosubst.awk < $(srcdir)/$< > $@
221 chmod +x $@