aboutsummaryrefslogtreecommitdiff
path: root/src/dht/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/dht/Makefile.am')
-rw-r--r--src/dht/Makefile.am51
1 files changed, 51 insertions, 0 deletions
diff --git a/src/dht/Makefile.am b/src/dht/Makefile.am
new file mode 100644
index 000000000..333034ecd
--- /dev/null
+++ b/src/dht/Makefile.am
@@ -0,0 +1,51 @@
1INCLUDES = -I$(top_srcdir)/src/include
2
3if MINGW
4 WINFLAGS = -Wl,--no-undefined -Wl,--export-all-symbols -lole32 -lshell32 -luuid -liconv -lstdc++ -lcomdlg32 -lgdi32
5endif
6
7if USE_COVERAGE
8 AM_CFLAGS = --coverage -O0
9 XLIB = -lgcov
10endif
11
12lib_LTLIBRARIES = libgnunetdht.la
13
14libgnunetdht_la_SOURCES = \
15 dht_api.c dht.h
16libgnunetdht_la_LIBADD = \
17 $(top_builddir)/src/util/libgnunetutil.la \
18 $(XLIB)
19libgnunetdht_la_LDFLAGS = \
20 $(GN_LIB_LDFLAGS) $(WINFLAGS) \
21 -version-info 0:0:0
22
23
24bin_PROGRAMS = \
25 gnunet-service-dht
26
27gnunet_service_dht_SOURCES = \
28 gnunet-service-dht.c
29gnunet_service_dht_LDADD = \
30 $(top_builddir)/src/statistics/libgnunetstatistics.la \
31 $(top_builddir)/src/core/libgnunetcore.la \
32 $(top_builddir)/src/datastore/libgnunetdatastore.la \
33 $(top_builddir)/src/util/libgnunetutil.la
34
35
36check_PROGRAMS = \
37 test_dht_api
38
39TESTS = $(check_PROGRAMS) # $(check_SCRIPTS)
40
41test_dht_api_SOURCES = \
42 test_dht_api.c
43test_dht_api_LDADD = \
44 $(top_builddir)/src/util/libgnunetutil.la \
45 $(top_builddir)/src/dht/libgnunetdht.la
46
47EXTRA_DIST = \
48 test_dht_api_data.conf
49
50#check_SCRIPTS = \
51# test_gnunet_peerinfo.sh