aboutsummaryrefslogtreecommitdiff
path: root/src/dht/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/dht/Makefile.am')
-rw-r--r--src/dht/Makefile.am35
1 files changed, 29 insertions, 6 deletions
diff --git a/src/dht/Makefile.am b/src/dht/Makefile.am
index a365c5e82..982c33815 100644
--- a/src/dht/Makefile.am
+++ b/src/dht/Makefile.am
@@ -109,6 +109,17 @@ gnunet_dht_monitor_DEPENDENCIES = \
109 libgnunetdht.la 109 libgnunetdht.la
110 110
111 111
112noinst_LIBRARIES = libgnunetdhttest.a
113
114libgnunetdhttest_a_SOURCES = \
115 dht_test_lib.c dht_test_lib.h
116libgnunetdhttest_a_LIBADD = \
117 $(top_builddir)/src/util/libgnunetutil.la \
118 $(top_builddir)/src/testbed/libgnunettestbed.la \
119 $(top_builddir)/src/dht/libgnunetdht.la
120libgnunetdhttest_a_DEPENDENCIES = \
121 libgnunetdht.la
122
112check_PROGRAMS = \ 123check_PROGRAMS = \
113 test_dht_api \ 124 test_dht_api \
114 test_dht_twopeer \ 125 test_dht_twopeer \
@@ -120,15 +131,18 @@ check_PROGRAMS = \
120 test_dht_2dtorus \ 131 test_dht_2dtorus \
121 test_dht_monitor 132 test_dht_monitor
122 133
134if HAVE_EXPERIMENTAL
135 NEW_TESTS = test_dht_line test_dht_2dtorus
136endif
137
123if ENABLE_TEST_RUN 138if ENABLE_TEST_RUN
124TESTS = test_dht_api $(check_SCRIPTS) \ 139TESTS = test_dht_api $(check_SCRIPTS) \
125 test_dht_twopeer \ 140 test_dht_twopeer \
126 test_dht_twopeer_put_get \ 141 test_dht_twopeer_put_get \
127 test_dht_twopeer_get_put \ 142 test_dht_twopeer_get_put \
128 test_dht_twopeer_path_tracking \ 143 test_dht_twopeer_path_tracking \
129 test_dht_multipeer \ 144 test_dht_multipeer \
130 test_dht_line \ 145 $(NEW_TESTS) \
131 test_dht_2dtorus \
132 test_dht_monitor 146 test_dht_monitor
133endif 147endif
134 148
@@ -142,6 +156,7 @@ test_dht_api_LDADD = \
142test_dht_api_DEPENDENCIES = \ 156test_dht_api_DEPENDENCIES = \
143 libgnunetdht.la 157 libgnunetdht.la
144 158
159# twopeer is obsolete once new test_dht_topo works...
145test_dht_twopeer_SOURCES = \ 160test_dht_twopeer_SOURCES = \
146 test_dht_twopeer.c 161 test_dht_twopeer.c
147test_dht_twopeer_LDADD = \ 162test_dht_twopeer_LDADD = \
@@ -151,6 +166,7 @@ test_dht_twopeer_LDADD = \
151test_dht_twopeer_DEPENDENCIES = \ 166test_dht_twopeer_DEPENDENCIES = \
152 libgnunetdht.la 167 libgnunetdht.la
153 168
169# twopeer_put_get is obsolete once new test_dht_topo works...
154test_dht_twopeer_put_get_SOURCES = \ 170test_dht_twopeer_put_get_SOURCES = \
155 test_dht_twopeer_put_get.c 171 test_dht_twopeer_put_get.c
156test_dht_twopeer_put_get_LDADD = \ 172test_dht_twopeer_put_get_LDADD = \
@@ -158,6 +174,7 @@ test_dht_twopeer_put_get_LDADD = \
158 $(top_builddir)/src/testing_old/libgnunettesting_old.la \ 174 $(top_builddir)/src/testing_old/libgnunettesting_old.la \
159 $(top_builddir)/src/dht/libgnunetdht.la 175 $(top_builddir)/src/dht/libgnunetdht.la
160 176
177# twopeer_get_put is obsolete once new test_dht_topo works...
161test_dht_twopeer_get_put_SOURCES = \ 178test_dht_twopeer_get_put_SOURCES = \
162 test_dht_twopeer_get_put.c 179 test_dht_twopeer_get_put.c
163test_dht_twopeer_get_put_LDADD = \ 180test_dht_twopeer_get_put_LDADD = \
@@ -165,6 +182,7 @@ test_dht_twopeer_get_put_LDADD = \
165 $(top_builddir)/src/testing_old/libgnunettesting_old.la \ 182 $(top_builddir)/src/testing_old/libgnunettesting_old.la \
166 $(top_builddir)/src/dht/libgnunetdht.la 183 $(top_builddir)/src/dht/libgnunetdht.la
167 184
185# twopeer_path_tracking is obsolete once new test_dht_topo works...
168test_dht_twopeer_path_tracking_SOURCES = \ 186test_dht_twopeer_path_tracking_SOURCES = \
169 test_dht_twopeer_path_tracking.c 187 test_dht_twopeer_path_tracking.c
170test_dht_twopeer_path_tracking_LDADD = \ 188test_dht_twopeer_path_tracking_LDADD = \
@@ -172,6 +190,8 @@ test_dht_twopeer_path_tracking_LDADD = \
172 $(top_builddir)/src/testing_old/libgnunettesting_old.la \ 190 $(top_builddir)/src/testing_old/libgnunettesting_old.la \
173 $(top_builddir)/src/dht/libgnunetdht.la 191 $(top_builddir)/src/dht/libgnunetdht.la
174 192
193# statistics functions should be integrated with test_dht_topo,
194# then this one also becomes obsolete...
175test_dht_multipeer_SOURCES = \ 195test_dht_multipeer_SOURCES = \
176 test_dht_multipeer.c 196 test_dht_multipeer.c
177test_dht_multipeer_LDADD = \ 197test_dht_multipeer_LDADD = \
@@ -185,8 +205,9 @@ test_dht_multipeer_DEPENDENCIES = \
185test_dht_2dtorus_SOURCES = \ 205test_dht_2dtorus_SOURCES = \
186 test_dht_topo.c 206 test_dht_topo.c
187test_dht_2dtorus_LDADD = \ 207test_dht_2dtorus_LDADD = \
208 $(top_builddir)/src/dht/libgnunetdhttest.a \
188 $(top_builddir)/src/util/libgnunetutil.la \ 209 $(top_builddir)/src/util/libgnunetutil.la \
189 $(top_builddir)/src/testing_old/libgnunettesting_old.la \ 210 $(top_builddir)/src/testbed/libgnunettestbed.la \
190 $(top_builddir)/src/dht/libgnunetdht.la 211 $(top_builddir)/src/dht/libgnunetdht.la
191test_dht_2dtorus_DEPENDENCIES = \ 212test_dht_2dtorus_DEPENDENCIES = \
192 libgnunetdht.la 213 libgnunetdht.la
@@ -194,12 +215,14 @@ test_dht_2dtorus_DEPENDENCIES = \
194test_dht_line_SOURCES = \ 215test_dht_line_SOURCES = \
195 test_dht_topo.c 216 test_dht_topo.c
196test_dht_line_LDADD = \ 217test_dht_line_LDADD = \
218 $(top_builddir)/src/dht/libgnunetdhttest.a \
197 $(top_builddir)/src/util/libgnunetutil.la \ 219 $(top_builddir)/src/util/libgnunetutil.la \
198 $(top_builddir)/src/testing_old/libgnunettesting_old.la \ 220 $(top_builddir)/src/testbed/libgnunettestbed.la \
199 $(top_builddir)/src/dht/libgnunetdht.la 221 $(top_builddir)/src/dht/libgnunetdht.la
200test_dht_line_DEPENDENCIES = \ 222test_dht_line_DEPENDENCIES = \
201 libgnunetdht.la 223 libgnunetdht.la
202 224
225# fixme, rewrite based on test_dht_topo.c!
203test_dht_monitor_SOURCES = test_dht_monitor.c 226test_dht_monitor_SOURCES = test_dht_monitor.c
204test_dht_monitor_LDADD = \ 227test_dht_monitor_LDADD = \
205 $(top_builddir)/src/util/libgnunetutil.la \ 228 $(top_builddir)/src/util/libgnunetutil.la \