aboutsummaryrefslogtreecommitdiff
path: root/src/dht/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/dht/Makefile.am')
-rw-r--r--src/dht/Makefile.am13
1 files changed, 12 insertions, 1 deletions
diff --git a/src/dht/Makefile.am b/src/dht/Makefile.am
index c75525ee3..a7d22c0ed 100644
--- a/src/dht/Makefile.am
+++ b/src/dht/Makefile.am
@@ -212,7 +212,18 @@ EXTRA_DIST = \
212 test_dht_multipeer_data.conf \ 212 test_dht_multipeer_data.conf \
213 test_dht_2dtorus.conf \ 213 test_dht_2dtorus.conf \
214 test_dht_line.conf \ 214 test_dht_line.conf \
215 test_dht_tools.py.in \
215 multipeer_topo.dat 216 multipeer_topo.dat
216 217
217check_SCRIPTS = \ 218check_SCRIPTS = \
218 test_dht_tools.sh 219 test_dht_tools.py
220
221do_subst = $(SED) -e 's,[@]PYTHON[@],$(PYTHON),g'
222
223%.py: %.py.in Makefile
224 $(do_subst) < $(srcdir)/$< > $@
225 chmod +x $@
226
227test_dht_tools.py: test_dht_tools.py.in Makefile
228 $(do_subst) < $(srcdir)/test_dht_tools.py.in > test_dht_tools.py
229 chmod +x test_dht_tools.py