aboutsummaryrefslogtreecommitdiff
path: root/src/dht/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/dht/meson.build')
-rw-r--r--src/dht/meson.build38
1 files changed, 38 insertions, 0 deletions
diff --git a/src/dht/meson.build b/src/dht/meson.build
new file mode 100644
index 000000000..130cef644
--- /dev/null
+++ b/src/dht/meson.build
@@ -0,0 +1,38 @@
1libgnunetdht_src = ['dht_api.c']
2
3libgnunetpluginblockdht_src = ['plugin_block_dht.c']
4
5gnunetservicedht_src = ['gnunet-service-dht.c',
6 'gnunet-service-dht_datacache.c',
7 'gnunet-service-dht_neighbours.c',
8 'gnunet-service-dht_routing.c']
9
10
11if gnunet_monolith == false
12 libgnunetdht = library('gnunetdht',
13 libgnunetdht_src,
14 dependencies: libgnunetutil_dep,
15 include_directories: [incdir, configuration_inc])
16 libgnunetdht_dep = declare_dependency(link_with : libgnunetdht)
17 libgnunetpluginblockdht = library('gnunet_plugin_block_dht',
18 libgnunetpluginblockdht_src,
19 dependencies: [libgnunetutil_dep,
20 libgnunethello_dep,
21 libgnunetblock_dep,
22 libgnunetblockgroup_dep],
23 include_directories: [incdir, configuration_inc])
24 libgnunetpluginblockdht_dep = declare_dependency(link_with : libgnunetpluginblockdht)
25 executable ('gnunet-service-dht',
26 gnunetservicedht_src,
27 dependencies: [libgnunetdht_dep, libgnunetutil_dep,
28 libgnunetblock_dep,
29 libgnunetdatacache_dep,
30 libgnunetstatistics_dep,
31 libgnunetblockgroup_dep,
32 libgnunethello_dep],
33 include_directories: [incdir, configuration_inc])
34else
35 foreach p : libgnunetdht_src + gnunetservicedht_src
36 gnunet_src += 'dht/' + p
37 endforeach
38endif