aboutsummaryrefslogtreecommitdiff
path: root/src/dns/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/dns/Makefile.am')
-rw-r--r--src/dns/Makefile.am252
1 files changed, 126 insertions, 126 deletions
diff --git a/src/dns/Makefile.am b/src/dns/Makefile.am
index e2f9a0783..a8ff4265d 100644
--- a/src/dns/Makefile.am
+++ b/src/dns/Makefile.am
@@ -1,126 +1,126 @@
1# This Makefile.am is in the public domain 1# This Makefile.am is in the public domain
2AM_CPPFLAGS = -I$(top_srcdir)/src/include 2AM_CPPFLAGS = -I$(top_srcdir)/src/include
3 3
4if MINGW 4if MINGW
5 WINFLAGS = -Wl,--no-undefined -Wl,--export-all-symbols 5 WINFLAGS = -Wl,--no-undefined -Wl,--export-all-symbols
6endif 6endif
7 7
8if USE_COVERAGE 8if USE_COVERAGE
9 AM_CFLAGS = --coverage -O0 9 AM_CFLAGS = --coverage -O0
10endif 10endif
11 11
12pkgcfgdir= $(pkgdatadir)/config.d/ 12pkgcfgdir= $(pkgdatadir)/config.d/
13 13
14libexecdir= $(pkglibdir)/libexec/ 14libexecdir= $(pkglibdir)/libexec/
15 15
16plugindir = $(libdir)/gnunet 16plugindir = $(libdir)/gnunet
17 17
18pkgcfg_DATA = \ 18pkgcfg_DATA = \
19 dns.conf 19 dns.conf
20 20
21if LINUX 21if LINUX
22HIJACKBIN = gnunet-helper-dns 22HIJACKBIN = gnunet-helper-dns
23install-exec-hook: 23install-exec-hook:
24 $(top_srcdir)/src/dns/install-dns-helper.sh $(libexecdir) $(GNUNETDNS_GROUP) $(SUDO_BINARY) || true 24 $(top_srcdir)/src/dns/install-dns-helper.sh $(libexecdir) $(GNUNETDNS_GROUP) $(SUDO_BINARY) || true
25else 25else
26install-exec-hook: 26install-exec-hook:
27endif 27endif
28 28
29lib_LTLIBRARIES = \ 29lib_LTLIBRARIES = \
30 libgnunetdnsparser.la \ 30 libgnunetdnsparser.la \
31 libgnunetdnsstub.la \ 31 libgnunetdnsstub.la \
32 libgnunetdns.la 32 libgnunetdns.la
33 33
34libexec_PROGRAMS = \ 34libexec_PROGRAMS = \
35 gnunet-service-dns $(HIJACKBIN) 35 gnunet-service-dns $(HIJACKBIN)
36 36
37noinst_PROGRAMS = \ 37noinst_PROGRAMS = \
38 gnunet-dns-monitor gnunet-dns-redirector 38 gnunet-dns-monitor gnunet-dns-redirector
39 39
40plugin_LTLIBRARIES = \ 40plugin_LTLIBRARIES = \
41 libgnunet_plugin_block_dns.la 41 libgnunet_plugin_block_dns.la
42 42
43if LINUX 43if LINUX
44check_SCRIPTS = \ 44check_SCRIPTS = \
45 test_gnunet_dns.sh 45 test_gnunet_dns.sh
46endif 46endif
47 47
48check_PROGRAMS = \ 48check_PROGRAMS = \
49 test_hexcoder 49 test_hexcoder
50 50
51gnunet_helper_dns_SOURCES = \ 51gnunet_helper_dns_SOURCES = \
52 gnunet-helper-dns.c 52 gnunet-helper-dns.c
53 53
54 54
55gnunet_dns_monitor_SOURCES = \ 55gnunet_dns_monitor_SOURCES = \
56 gnunet-dns-monitor.c 56 gnunet-dns-monitor.c
57gnunet_dns_monitor_LDADD = \ 57gnunet_dns_monitor_LDADD = \
58 libgnunetdnsparser.la \ 58 libgnunetdnsparser.la \
59 libgnunetdns.la \ 59 libgnunetdns.la \
60 $(top_builddir)/src/util/libgnunetutil.la \ 60 $(top_builddir)/src/util/libgnunetutil.la \
61 $(GN_LIBINTL) 61 $(GN_LIBINTL)
62 62
63gnunet_dns_redirector_SOURCES = \ 63gnunet_dns_redirector_SOURCES = \
64 gnunet-dns-redirector.c 64 gnunet-dns-redirector.c
65gnunet_dns_redirector_LDADD = \ 65gnunet_dns_redirector_LDADD = \
66 libgnunetdnsparser.la \ 66 libgnunetdnsparser.la \
67 libgnunetdns.la \ 67 libgnunetdns.la \
68 $(top_builddir)/src/util/libgnunetutil.la \ 68 $(top_builddir)/src/util/libgnunetutil.la \
69 $(GN_LIBINTL) 69 $(GN_LIBINTL)
70 70
71gnunet_service_dns_SOURCES = \ 71gnunet_service_dns_SOURCES = \
72 gnunet-service-dns.c 72 gnunet-service-dns.c
73gnunet_service_dns_LDADD = \ 73gnunet_service_dns_LDADD = \
74 libgnunetdnsstub.la \ 74 libgnunetdnsstub.la \
75 $(top_builddir)/src/tun/libgnunettun.la \ 75 $(top_builddir)/src/tun/libgnunettun.la \
76 $(top_builddir)/src/statistics/libgnunetstatistics.la \ 76 $(top_builddir)/src/statistics/libgnunetstatistics.la \
77 $(top_builddir)/src/util/libgnunetutil.la \ 77 $(top_builddir)/src/util/libgnunetutil.la \
78 $(GN_LIBINTL) 78 $(GN_LIBINTL)
79 79
80libgnunetdnsparser_la_SOURCES = \ 80libgnunetdnsparser_la_SOURCES = \
81 dnsparser.c 81 dnsparser.c
82libgnunetdnsparser_la_LIBADD = \ 82libgnunetdnsparser_la_LIBADD = \
83 $(top_builddir)/src/util/libgnunetutil.la $(XLIB) \ 83 $(top_builddir)/src/util/libgnunetutil.la $(XLIB) \
84 -lidn 84 -lidn
85libgnunetdnsparser_la_LDFLAGS = \ 85libgnunetdnsparser_la_LDFLAGS = \
86 $(GN_LIB_LDFLAGS) \ 86 $(GN_LIB_LDFLAGS) \
87 -version-info 1:0:1 87 -version-info 1:0:1
88 88
89libgnunetdnsstub_la_SOURCES = \ 89libgnunetdnsstub_la_SOURCES = \
90 dnsstub.c 90 dnsstub.c
91libgnunetdnsstub_la_LIBADD = \ 91libgnunetdnsstub_la_LIBADD = \
92 $(top_builddir)/src/util/libgnunetutil.la $(XLIB) 92 $(top_builddir)/src/util/libgnunetutil.la $(XLIB)
93libgnunetdnsstub_la_LDFLAGS = \ 93libgnunetdnsstub_la_LDFLAGS = \
94 $(GN_LIB_LDFLAGS) \ 94 $(GN_LIB_LDFLAGS) \
95 -version-info 0:0:0 95 -version-info 0:0:0
96 96
97libgnunetdns_la_SOURCES = \ 97libgnunetdns_la_SOURCES = \
98 dns_api.c dns.h 98 dns_api.c dns.h
99libgnunetdns_la_LIBADD = \ 99libgnunetdns_la_LIBADD = \
100 $(top_builddir)/src/util/libgnunetutil.la $(XLIB) 100 $(top_builddir)/src/util/libgnunetutil.la $(XLIB)
101libgnunetdns_la_LDFLAGS = \ 101libgnunetdns_la_LDFLAGS = \
102 $(GN_LIB_LDFLAGS) \ 102 $(GN_LIB_LDFLAGS) \
103 -version-info 0:0:0 103 -version-info 0:0:0
104 104
105libgnunet_plugin_block_dns_la_SOURCES = \ 105libgnunet_plugin_block_dns_la_SOURCES = \
106 plugin_block_dns.c 106 plugin_block_dns.c
107libgnunet_plugin_block_dns_la_LIBADD = \ 107libgnunet_plugin_block_dns_la_LIBADD = \
108 $(top_builddir)/src/util/libgnunetutil.la 108 $(top_builddir)/src/util/libgnunetutil.la
109libgnunet_plugin_block_dns_la_LDFLAGS = \ 109libgnunet_plugin_block_dns_la_LDFLAGS = \
110 $(top_builddir)/src/block/$(GN_PLUGIN_LDFLAGS) 110 $(top_builddir)/src/block/$(GN_PLUGIN_LDFLAGS)
111 111
112 112
113if ENABLE_TEST_RUN 113if ENABLE_TEST_RUN
114AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH; 114AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;
115TESTS = $(check_PROGRAMS) $(check_SCRIPTS) 115TESTS = $(check_PROGRAMS) $(check_SCRIPTS)
116endif 116endif
117 117
118EXTRA_DIST = \ 118EXTRA_DIST = \
119 $(check_SCRIPTS) 119 $(check_SCRIPTS)
120 120
121 121
122test_hexcoder_SOURCES = \ 122test_hexcoder_SOURCES = \
123 test_hexcoder.c 123 test_hexcoder.c
124test_hexcoder_LDADD = \ 124test_hexcoder_LDADD = \
125 libgnunetdnsparser.la \ 125 libgnunetdnsparser.la \
126 $(top_builddir)/src/util/libgnunetutil.la 126 $(top_builddir)/src/util/libgnunetutil.la