aboutsummaryrefslogtreecommitdiff
path: root/src/dns/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/dns/Makefile.am')
-rw-r--r--src/dns/Makefile.am34
1 files changed, 34 insertions, 0 deletions
diff --git a/src/dns/Makefile.am b/src/dns/Makefile.am
index ca2685765..9a4ecdcfd 100644
--- a/src/dns/Makefile.am
+++ b/src/dns/Makefile.am
@@ -27,6 +27,8 @@ install-exec-hook:
27endif 27endif
28 28
29lib_LTLIBRARIES = \ 29lib_LTLIBRARIES = \
30 libgnunetdnsparser.la \
31 libgnunetdnsstub.la \
30 libgnunetdns.la 32 libgnunetdns.la
31 33
32libexec_PROGRAMS = \ 34libexec_PROGRAMS = \
@@ -45,6 +47,9 @@ check_SCRIPTS = \
45 test_gnunet_dns.sh 47 test_gnunet_dns.sh
46endif 48endif
47 49
50check_PROGRAMS = \
51 test_hexcoder
52
48gnunet_helper_dns_SOURCES = \ 53gnunet_helper_dns_SOURCES = \
49 gnunet-helper-dns.c 54 gnunet-helper-dns.c
50 55
@@ -52,6 +57,7 @@ gnunet_helper_dns_SOURCES = \
52gnunet_dns_monitor_SOURCES = \ 57gnunet_dns_monitor_SOURCES = \
53 gnunet-dns-monitor.c 58 gnunet-dns-monitor.c
54gnunet_dns_monitor_LDADD = \ 59gnunet_dns_monitor_LDADD = \
60 libgnunetdnsparser.la \
55 libgnunetdns.la \ 61 libgnunetdns.la \
56 $(top_builddir)/src/util/libgnunetutil.la \ 62 $(top_builddir)/src/util/libgnunetutil.la \
57 $(GN_LIBINTL) 63 $(GN_LIBINTL)
@@ -59,12 +65,15 @@ gnunet_dns_monitor_LDADD = \
59gnunet_zonewalk_SOURCES = \ 65gnunet_zonewalk_SOURCES = \
60 gnunet-zonewalk.c 66 gnunet-zonewalk.c
61gnunet_zonewalk_LDADD = \ 67gnunet_zonewalk_LDADD = \
68 libgnunetdnsparser.la \
69 libgnunetdnsstub.la \
62 $(top_builddir)/src/util/libgnunetutil.la \ 70 $(top_builddir)/src/util/libgnunetutil.la \
63 $(GN_LIBINTL) 71 $(GN_LIBINTL)
64 72
65gnunet_dns_redirector_SOURCES = \ 73gnunet_dns_redirector_SOURCES = \
66 gnunet-dns-redirector.c 74 gnunet-dns-redirector.c
67gnunet_dns_redirector_LDADD = \ 75gnunet_dns_redirector_LDADD = \
76 libgnunetdnsparser.la \
68 libgnunetdns.la \ 77 libgnunetdns.la \
69 $(top_builddir)/src/util/libgnunetutil.la \ 78 $(top_builddir)/src/util/libgnunetutil.la \
70 $(GN_LIBINTL) 79 $(GN_LIBINTL)
@@ -72,10 +81,30 @@ gnunet_dns_redirector_LDADD = \
72gnunet_service_dns_SOURCES = \ 81gnunet_service_dns_SOURCES = \
73 gnunet-service-dns.c 82 gnunet-service-dns.c
74gnunet_service_dns_LDADD = \ 83gnunet_service_dns_LDADD = \
84 libgnunetdnsstub.la \
85 $(top_builddir)/src/tun/libgnunettun.la \
75 $(top_builddir)/src/statistics/libgnunetstatistics.la \ 86 $(top_builddir)/src/statistics/libgnunetstatistics.la \
76 $(top_builddir)/src/util/libgnunetutil.la \ 87 $(top_builddir)/src/util/libgnunetutil.la \
77 $(GN_LIBINTL) 88 $(GN_LIBINTL)
78 89
90libgnunetdnsparser_la_SOURCES = \
91 dnsparser.c
92libgnunetdnsparser_la_LIBADD = \
93 $(top_builddir)/src/util/libgnunetutil.la $(XLIB) \
94 -lidn
95libgnunetdnsparser_la_LDFLAGS = \
96 $(GN_LIB_LDFLAGS) \
97 -version-info 1:0:1
98
99libgnunetdnsstub_la_SOURCES = \
100 dnsstub.c
101libgnunetdnsstub_la_LIBADD = \
102 $(top_builddir)/src/tun/libgnunettun.la \
103 $(top_builddir)/src/util/libgnunetutil.la $(XLIB)
104libgnunetdnsstub_la_LDFLAGS = \
105 $(GN_LIB_LDFLAGS) \
106 -version-info 0:0:0
107
79libgnunetdns_la_SOURCES = \ 108libgnunetdns_la_SOURCES = \
80 dns_api.c dns.h 109 dns_api.c dns.h
81libgnunetdns_la_LIBADD = \ 110libgnunetdns_la_LIBADD = \
@@ -102,3 +131,8 @@ EXTRA_DIST = \
102 $(check_SCRIPTS) 131 $(check_SCRIPTS)
103 132
104 133
134test_hexcoder_SOURCES = \
135 test_hexcoder.c
136test_hexcoder_LDADD = \
137 libgnunetdnsparser.la \
138 $(top_builddir)/src/util/libgnunetutil.la