aboutsummaryrefslogtreecommitdiff
path: root/src/dv/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/dv/Makefile.am')
-rw-r--r--src/dv/Makefile.am17
1 files changed, 5 insertions, 12 deletions
diff --git a/src/dv/Makefile.am b/src/dv/Makefile.am
index 0fa26a90d..e9e2bba3f 100644
--- a/src/dv/Makefile.am
+++ b/src/dv/Makefile.am
@@ -23,10 +23,9 @@ lib_LTLIBRARIES = libgnunetdv.la
23plugin_LTLIBRARIES = libgnunet_plugin_transport_dv.la 23plugin_LTLIBRARIES = libgnunet_plugin_transport_dv.la
24 24
25libgnunetdv_la_SOURCES = \ 25libgnunetdv_la_SOURCES = \
26 dv_api.c dv.h 26 dv_api.c dv.h gnunet_dv_service.h
27libgnunetdv_la_LIBADD = \ 27libgnunetdv_la_LIBADD = \
28 $(top_builddir)/src/util/libgnunetutil.la \ 28 $(top_builddir)/src/util/libgnunetutil.la \
29 $(top_builddir)/src/core/libgnunetcore.la \
30 $(GN_LIBINTL) $(XLIB) 29 $(GN_LIBINTL) $(XLIB)
31libgnunetdv_la_LDFLAGS = \ 30libgnunetdv_la_LDFLAGS = \
32 $(GN_LIB_LDFLAGS) $(WINFLAGS) \ 31 $(GN_LIB_LDFLAGS) $(WINFLAGS) \
@@ -37,24 +36,17 @@ libexec_PROGRAMS = \
37 gnunet-service-dv 36 gnunet-service-dv
38 37
39gnunet_service_dv_SOURCES = \ 38gnunet_service_dv_SOURCES = \
40 gnunet-service-dv.c 39 gnunet-service-dv.c dv.h
41gnunet_service_dv_LDADD = \ 40gnunet_service_dv_LDADD = \
42 $(top_builddir)/src/statistics/libgnunetstatistics.la \ 41 $(top_builddir)/src/statistics/libgnunetstatistics.la \
43 $(top_builddir)/src/dv/libgnunetdv.la \
44 $(top_builddir)/src/core/libgnunetcore.la \ 42 $(top_builddir)/src/core/libgnunetcore.la \
45 $(top_builddir)/src/hello/libgnunethello.la \
46 $(top_builddir)/src/peerinfo/libgnunetpeerinfo.la \
47 $(top_builddir)/src/util/libgnunetutil.la \ 43 $(top_builddir)/src/util/libgnunetutil.la \
48 $(GN_LIBINTL) 44 $(GN_LIBINTL)
49gnunet_service_dv_DEPENDENCIES = \
50 libgnunetdv.la
51 45
52libgnunet_plugin_transport_dv_la_SOURCES = \ 46libgnunet_plugin_transport_dv_la_SOURCES = \
53 plugin_transport_dv.c 47 plugin_transport_dv.c
54libgnunet_plugin_transport_dv_la_LIBADD = \ 48libgnunet_plugin_transport_dv_la_LIBADD = \
55 $(top_builddir)/src/hello/libgnunethello.la \ 49 libgnunetdv.la \
56 $(top_builddir)/src/dv/libgnunetdv.la \
57 $(top_builddir)/src/peerinfo/libgnunetpeerinfo.la \
58 $(top_builddir)/src/util/libgnunetutil.la 50 $(top_builddir)/src/util/libgnunetutil.la
59libgnunet_plugin_transport_dv_la_LDFLAGS = \ 51libgnunet_plugin_transport_dv_la_LDFLAGS = \
60 $(GN_PLUGIN_LDFLAGS) 52 $(GN_PLUGIN_LDFLAGS)
@@ -77,4 +69,5 @@ endif
77# $(top_builddir)/src/util/libgnunetutil.la 69# $(top_builddir)/src/util/libgnunetutil.la
78 70
79EXTRA_DIST = \ 71EXTRA_DIST = \
80 test_transport_dv_data.conf 72 test_transport_dv_data.conf
73