aboutsummaryrefslogtreecommitdiff
path: root/src/exit/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/exit/Makefile.am')
-rw-r--r--src/exit/Makefile.am10
1 files changed, 6 insertions, 4 deletions
diff --git a/src/exit/Makefile.am b/src/exit/Makefile.am
index bc41e5c2c..dd030e7a4 100644
--- a/src/exit/Makefile.am
+++ b/src/exit/Makefile.am
@@ -10,6 +10,8 @@ endif
10 10
11pkgcfgdir= $(pkgdatadir)/config.d/ 11pkgcfgdir= $(pkgdatadir)/config.d/
12 12
13libexecdir= $(pkglibdir)/libexec/
14
13plugindir = $(libdir)/gnunet 15plugindir = $(libdir)/gnunet
14 16
15dist_pkgcfg_DATA = \ 17dist_pkgcfg_DATA = \
@@ -18,15 +20,15 @@ dist_pkgcfg_DATA = \
18if LINUX 20if LINUX
19EXITBIN = gnunet-helper-exit 21EXITBIN = gnunet-helper-exit
20install-exec-hook: 22install-exec-hook:
21 $(top_srcdir)/src/exit/install-exit-helper.sh $(bindir) $(SUDO_BINARY) || true 23 $(top_srcdir)/src/exit/install-exit-helper.sh $(libexecdir) $(SUDO_BINARY) || true
22else 24else
23install-exec-hook: 25install-exec-hook:
24endif 26endif
25 27
26 28
27bin_PROGRAMS = \ 29libexec_PROGRAMS = \
28 gnunet-daemon-exit $(EXITBIN) 30 gnunet-daemon-exit \
29 31 $(EXITBIN)
30 32
31gnunet_helper_exit_SOURCES = \ 33gnunet_helper_exit_SOURCES = \
32 gnunet-helper-exit.c 34 gnunet-helper-exit.c