aboutsummaryrefslogtreecommitdiff
path: root/src/fragmentation/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/fragmentation/meson.build')
-rw-r--r--src/fragmentation/meson.build22
1 files changed, 0 insertions, 22 deletions
diff --git a/src/fragmentation/meson.build b/src/fragmentation/meson.build
deleted file mode 100644
index 411812d0d..000000000
--- a/src/fragmentation/meson.build
+++ /dev/null
@@ -1,22 +0,0 @@
1libgnunetfragmentation_src = ['fragmentation.c',
2 'defragmentation.c']
3
4if get_option('monolith')
5 foreach p : libgnunetfragmentation_src
6 gnunet_src += 'fragmentation/' + p
7 endforeach
8 subdir_done()
9endif
10
11libgnunetfragmentation = library('gnunetfragmentation',
12 libgnunetfragmentation_src,
13 soversion: '2',
14 version: '2.0.0',
15 dependencies: [m_dep, libgnunetutil_dep, libgnunetstatistics_dep],
16 include_directories: [incdir, configuration_inc],
17 install: true,
18 install_dir: get_option('libdir'))
19libgnunetfragmentation_dep = declare_dependency(link_with : libgnunetfragmentation)
20pkg.generate(libgnunetfragmentation, url: 'https://www.gnunet.org',
21 description : 'Provides API for sending and receiving messages that are larger than the MTU of the transport')
22