aboutsummaryrefslogtreecommitdiff
path: root/src/fragmentation/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/fragmentation/meson.build')
-rw-r--r--src/fragmentation/meson.build21
1 files changed, 21 insertions, 0 deletions
diff --git a/src/fragmentation/meson.build b/src/fragmentation/meson.build
new file mode 100644
index 000000000..148a4efe8
--- /dev/null
+++ b/src/fragmentation/meson.build
@@ -0,0 +1,21 @@
1libgnunetfragmentation_src = ['fragmentation.c',
2 'defragmentation.c']
3
4if get_option('monolith')
5 foreach p : libgnunetfragmentation_src
6 gnunet_src += 'fragmentation/' + p
7 endforeach
8endif
9
10libgnunetfragmentation = library('gnunetfragmentation',
11 libgnunetfragmentation_src,
12 soversion: '2',
13 version: '2.0.0',
14 dependencies: [m_dep, libgnunetutil_dep, libgnunetstatistics_dep],
15 include_directories: [incdir, configuration_inc],
16 install: true,
17 install_dir: get_option('libdir'))
18libgnunetfragmentation_dep = declare_dependency(link_with : libgnunetfragmentation)
19pkg.generate(libgnunetfragmentation, url: 'https://www.gnunet.org',
20 description : 'Provides API for sending and receiving messages that are larger than the MTU of the transport')
21