aboutsummaryrefslogtreecommitdiff
path: root/src/fs/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/fs/Makefile.am')
-rw-r--r--src/fs/Makefile.am13
1 files changed, 11 insertions, 2 deletions
diff --git a/src/fs/Makefile.am b/src/fs/Makefile.am
index 5aca42ac2..f1bc64784 100644
--- a/src/fs/Makefile.am
+++ b/src/fs/Makefile.am
@@ -26,6 +26,7 @@ libgnunetfs_la_SOURCES = \
26 fs_uri.c 26 fs_uri.c
27 27
28libgnunetfs_la_LIBADD = \ 28libgnunetfs_la_LIBADD = \
29 $(top_builddir)/src/datastore/libgnunetdatastore.la \
29 $(top_builddir)/src/util/libgnunetutil.la \ 30 $(top_builddir)/src/util/libgnunetutil.la \
30 -lextractor \ 31 -lextractor \
31 $(GN_LIBINTL) $(XLIB) 32 $(GN_LIBINTL) $(XLIB)
@@ -35,11 +36,11 @@ libgnunetfs_la_LDFLAGS = \
35 -version-info 0:0:0 36 -version-info 0:0:0
36 37
37 38
38#bin_PROGRAMS = 39bin_PROGRAMS = \
40 gnunet-publish
39# gnunet-directory 41# gnunet-directory
40# gnunet-download 42# gnunet-download
41# gnunet-pseudonym 43# gnunet-pseudonym
42# gnunet-publish
43# gnunet-search 44# gnunet-search
44# gnunet-unindex 45# gnunet-unindex
45 46
@@ -51,6 +52,14 @@ libgnunetfs_la_LDFLAGS = \
51# $(GN_LIBINTL) 52# $(GN_LIBINTL)
52 53
53 54
55gnunet_publish_SOURCES = \
56 gnunet-publish.c
57gnunet_publish_LDADD = \
58 $(top_builddir)/src/fs/libgnunetfs.la \
59 $(top_builddir)/src/util/libgnunetutil.la \
60 $(GN_LIBINTL)
61
62
54check_PROGRAMS = \ 63check_PROGRAMS = \
55 test_fs_collection \ 64 test_fs_collection \
56 test_fs_directory \ 65 test_fs_directory \