aboutsummaryrefslogtreecommitdiff
path: root/src/fs/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/fs/Makefile.am')
-rw-r--r--src/fs/Makefile.am17
1 files changed, 15 insertions, 2 deletions
diff --git a/src/fs/Makefile.am b/src/fs/Makefile.am
index 2e994b95a..743d93e14 100644
--- a/src/fs/Makefile.am
+++ b/src/fs/Makefile.am
@@ -125,7 +125,8 @@ check_PROGRAMS = \
125 test_fs_search \ 125 test_fs_search \
126 test_fs_start_stop \ 126 test_fs_start_stop \
127 test_fs_unindex \ 127 test_fs_unindex \
128 test_fs_uri 128 test_fs_uri \
129 test_gnunet_service_fs_p2p
129 130
130TESTS = \ 131TESTS = \
131 test_fs_directory \ 132 test_fs_directory \
@@ -136,9 +137,11 @@ TESTS = \
136 test_fs_search \ 137 test_fs_search \
137 test_fs_start_stop \ 138 test_fs_start_stop \
138 test_fs_unindex \ 139 test_fs_unindex \
139 test_fs_uri 140 test_fs_uri \
141 test_gnunet_service_fs_p2p
140# $(check_PROGRAMS) 142# $(check_PROGRAMS)
141 143
144
142test_fs_collection_SOURCES = \ 145test_fs_collection_SOURCES = \
143 test_fs_collection.c 146 test_fs_collection.c
144test_fs_collection_LDADD = \ 147test_fs_collection_LDADD = \
@@ -217,11 +220,21 @@ test_fs_uri_LDADD = \
217 $(top_builddir)/src/fs/libgnunetfs.la \ 220 $(top_builddir)/src/fs/libgnunetfs.la \
218 $(top_builddir)/src/util/libgnunetutil.la 221 $(top_builddir)/src/util/libgnunetutil.la
219 222
223test_gnunet_service_fs_p2p_SOURCES = \
224 test_gnunet_service_fs_p2p.c
225test_gnunet_service_fs_p2p_LDADD = \
226 $(top_builddir)/src/fs/libgnunetfstest.a \
227 $(top_builddir)/src/testing/libgnunettesting.la \
228 $(top_builddir)/src/fs/libgnunetfs.la \
229 $(top_builddir)/src/util/libgnunetutil.la
230
231
220EXTRA_DIST = \ 232EXTRA_DIST = \
221 test_fs_data.conf \ 233 test_fs_data.conf \
222 test_fs_collection_data.conf \ 234 test_fs_collection_data.conf \
223 test_fs_download_data.conf \ 235 test_fs_download_data.conf \
224 test_fs_file_information_data.conf \ 236 test_fs_file_information_data.conf \
237 test_fs_lib_data.conf \
225 test_fs_list_indexed_data.conf \ 238 test_fs_list_indexed_data.conf \
226 test_fs_namespace_data.conf \ 239 test_fs_namespace_data.conf \
227 test_fs_publish_data.conf \ 240 test_fs_publish_data.conf \