aboutsummaryrefslogtreecommitdiff
path: root/src/fs/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/fs/Makefile.am')
-rw-r--r--src/fs/Makefile.am43
1 files changed, 1 insertions, 42 deletions
diff --git a/src/fs/Makefile.am b/src/fs/Makefile.am
index 83dd8e1bf..9a7ff0011 100644
--- a/src/fs/Makefile.am
+++ b/src/fs/Makefile.am
@@ -21,8 +21,6 @@ lib_LTLIBRARIES = libgnunetfs.la
21plugin_LTLIBRARIES = \ 21plugin_LTLIBRARIES = \
22 libgnunet_plugin_block_fs.la 22 libgnunet_plugin_block_fs.la
23 23
24# noinst_LIBRARIES = libgnunetfstest.a
25
26libgnunetfs_la_SOURCES = \ 24libgnunetfs_la_SOURCES = \
27 fs_api.c fs_api.h fs.h \ 25 fs_api.c fs_api.h fs.h \
28 fs_directory.c \ 26 fs_directory.c \
@@ -59,13 +57,6 @@ libgnunetfs_la_LDFLAGS = \
59 -version-info 3:1:1 57 -version-info 3:1:1
60 58
61 59
62#libgnunetfstest_a_SOURCES = \
63# fs_test_lib.c fs_test_lib.h
64#
65#libgnunetfstest_a_LIBADD = \
66# $(top_builddir)/src/testing/libgnunettesting.la \
67# $(top_builddir)/src/testbed/libgnunettestbed.la
68
69libexec_PROGRAMS = \ 60libexec_PROGRAMS = \
70 gnunet-helper-fs-publish \ 61 gnunet-helper-fs-publish \
71 gnunet-service-fs 62 gnunet-service-fs
@@ -94,15 +85,6 @@ gnunet_directory_LDADD += \
94 -lextractor 85 -lextractor
95endif 86endif
96 87
97# TNG
98#gnunet_fs_profiler_SOURCES = \
99# gnunet-fs-profiler.c
100#gnunet_fs_profiler_LDADD = \
101# $(top_builddir)/src/testing/libgnunettesting.la \
102# $(top_builddir)/src/testbed/libgnunettestbed.la \
103# $(top_builddir)/src/util/libgnunetutil.la \
104# $(GN_LIBINTL)
105
106gnunet_fs_SOURCES = \ 88gnunet_fs_SOURCES = \
107 gnunet-fs.c 89 gnunet-fs.c
108gnunet_fs_LDADD = \ 90gnunet_fs_LDADD = \
@@ -219,14 +201,6 @@ libgnunet_plugin_block_fs_la_LIBADD = \
219libgnunet_plugin_block_fs_la_LDFLAGS = \ 201libgnunet_plugin_block_fs_la_LDFLAGS = \
220 $(GN_PLUGIN_LDFLAGS) 202 $(GN_PLUGIN_LDFLAGS)
221 203
222#if HAVE_BENCHMARKS
223# FS_BENCHMARKS = \
224# perf_gnunet_service_fs_p2p \
225# perf_gnunet_service_fs_p2p_dht \
226# perf_gnunet_service_fs_p2p_index \
227# perf_gnunet_service_fs_p2p_respect
228#endif
229
230check_PROGRAMS = \ 204check_PROGRAMS = \
231 test_plugin_block_fs \ 205 test_plugin_block_fs \
232 test_fs_directory \ 206 test_fs_directory \
@@ -284,22 +258,7 @@ TESTS = test_fs_directory \
284 test_fs_search_persistence \ 258 test_fs_search_persistence \
285 test_fs_start_stop \ 259 test_fs_start_stop \
286 test_fs_uri \ 260 test_fs_uri \
287 test_fs_meta_data 261 test_fs_meta_data
288 # test_fs_download \
289 # test_fs_download_indexed \
290 # test_fs_download_persistence \
291 # test_fs_list_indexed \
292 # test_fs_publish \
293 # test_fs_publish_persistence \
294 # test_fs_unindex \
295 # test_fs_unindex_persistence \
296 # test_fs_test_lib \
297 # test_gnunet_service_fs_migration \
298 # test_gnunet_service_fs_p2p \
299 # test_gnunet_service_fs_p2p_cadet \
300 # perf_gnunet_service_fs_p2p \
301 # perf_gnunet_service_fs_p2p_index \
302 # perf_gnunet_service_fs_p2p_respect \
303 # $(check_SCRIPTS) 262 # $(check_SCRIPTS)
304endif 263endif
305 264