aboutsummaryrefslogtreecommitdiff
path: root/src/fs/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/fs/Makefile.am')
-rw-r--r--src/fs/Makefile.am29
1 files changed, 24 insertions, 5 deletions
diff --git a/src/fs/Makefile.am b/src/fs/Makefile.am
index d18d06dd7..e497f3e39 100644
--- a/src/fs/Makefile.am
+++ b/src/fs/Makefile.am
@@ -133,10 +133,6 @@ check_PROGRAMS = \
133 133
134 134
135if HAVE_PYTHON_PEXPECT 135if HAVE_PYTHON_PEXPECT
136TEST_EXTENSIONS = .py
137PY_LOG_COMPILER = $(PYTHON)
138AM_PY_LOG_FLAGS = -v
139
140check_SCRIPTS = \ 136check_SCRIPTS = \
141 test_gnunet_fs_psd.py \ 137 test_gnunet_fs_psd.py \
142 test_gnunet_fs_rec.py \ 138 test_gnunet_fs_rec.py \
@@ -254,6 +250,24 @@ test_gnunet_service_fs_p2p_LDADD = \
254 $(top_builddir)/src/fs/libgnunetfs.la \ 250 $(top_builddir)/src/fs/libgnunetfs.la \
255 $(top_builddir)/src/util/libgnunetutil.la 251 $(top_builddir)/src/util/libgnunetutil.la
256 252
253do_subst = $(SED) -e 's,[@]PYTHON[@],$(PYTHON),g'
254
255test_gnunet_fs_psd.py: test_gnunet_fs_psd.py.in Makefile
256 $(do_subst) < $(srcdir)/test_gnunet_fs_psd.py.in > test_gnunet_fs_psd.py
257 chmod +x test_gnunet_fs_psd.py
258
259test_gnunet_fs_rec.py: test_gnunet_fs_rec.py.in Makefile
260 $(do_subst) < $(srcdir)/test_gnunet_fs_rec.py.in > test_gnunet_fs_rec.py
261 chmod +x test_gnunet_fs_rec.py
262
263test_gnunet_fs_ns.py: test_gnunet_fs_ns.py.in Makefile
264 $(do_subst) < $(srcdir)/test_gnunet_fs_ns.py.in > test_gnunet_fs_ns.py
265 chmod +x test_gnunet_fs_ns.py
266
267test_gnunet_fs_idx.py: test_gnunet_fs_idx.py.in Makefile
268 $(do_subst) < $(srcdir)/test_gnunet_fs_idx.py.in > test_gnunet_fs_idx.py
269 chmod +x test_gnunet_fs_idx.py
270
257 271
258EXTRA_DIST = \ 272EXTRA_DIST = \
259 fs_test_lib_data.conf \ 273 fs_test_lib_data.conf \
@@ -273,4 +287,9 @@ EXTRA_DIST = \
273 test_gnunet_fs_psd_data.conf \ 287 test_gnunet_fs_psd_data.conf \
274 test_gnunet_fs_rec_data.conf \ 288 test_gnunet_fs_rec_data.conf \
275 test_gnunet_fs_rec_data.tgz \ 289 test_gnunet_fs_rec_data.tgz \
276 $(check_SCRIPTS) 290 test_gnunet_fs_psd.py.in \
291 test_gnunet_fs_rec.py.in \
292 test_gnunet_fs_ns.py.in \
293 test_gnunet_fs_idx.py.in
294
295CLEANFILES = $(check_SCRIPTS)