aboutsummaryrefslogtreecommitdiff
path: root/src/fs/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/fs/Makefile.am')
-rw-r--r--src/fs/Makefile.am20
1 files changed, 15 insertions, 5 deletions
diff --git a/src/fs/Makefile.am b/src/fs/Makefile.am
index 3d8ec2bac..7773c58ee 100644
--- a/src/fs/Makefile.am
+++ b/src/fs/Makefile.am
@@ -40,7 +40,8 @@ libgnunetfs_la_SOURCES = \
40 fs_sharetree.c \ 40 fs_sharetree.c \
41 fs_tree.c fs_tree.h \ 41 fs_tree.c fs_tree.h \
42 fs_unindex.c \ 42 fs_unindex.c \
43 fs_uri.c 43 fs_uri.c \
44 meta_data.c
44 45
45libgnunetfs_la_LIBADD = \ 46libgnunetfs_la_LIBADD = \
46 $(top_builddir)/src/datastore/libgnunetdatastore.la \ 47 $(top_builddir)/src/datastore/libgnunetdatastore.la \
@@ -148,8 +149,9 @@ endif
148gnunet_helper_fs_publish_SOURCES = \ 149gnunet_helper_fs_publish_SOURCES = \
149 gnunet-helper-fs-publish.c 150 gnunet-helper-fs-publish.c
150gnunet_helper_fs_publish_LDADD = \ 151gnunet_helper_fs_publish_LDADD = \
151 $(top_builddir)/src/util/libgnunetutil.la \ 152 libgnunetfs.la \
152 $(GN_LIBINTL) 153 $(top_builddir)/src/util/libgnunetutil.la \
154 $(GN_LIBINTL)
153 155
154if HAVE_LIBEXTRACTOR 156if HAVE_LIBEXTRACTOR
155gnunet_helper_fs_publish_LDADD += \ 157gnunet_helper_fs_publish_LDADD += \
@@ -249,6 +251,7 @@ check_PROGRAMS = \
249 test_fs_unindex \ 251 test_fs_unindex \
250 test_fs_unindex_persistence \ 252 test_fs_unindex_persistence \
251 test_fs_uri \ 253 test_fs_uri \
254 test_fs_meta_data \
252 test_gnunet_service_fs_migration \ 255 test_gnunet_service_fs_migration \
253 test_gnunet_service_fs_p2p \ 256 test_gnunet_service_fs_p2p \
254 test_gnunet_service_fs_p2p_cadet \ 257 test_gnunet_service_fs_p2p_cadet \
@@ -273,7 +276,7 @@ endif
273 276
274 277
275if ENABLE_TEST_RUN 278if ENABLE_TEST_RUN
276AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME; $(MONKEY) 279AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME;
277TESTS = \ 280TESTS = \
278 test_fs_directory \ 281 test_fs_directory \
279 test_fs_download \ 282 test_fs_download \
@@ -294,6 +297,7 @@ TESTS = \
294 test_fs_unindex_persistence \ 297 test_fs_unindex_persistence \
295 test_fs_uri \ 298 test_fs_uri \
296 test_fs_test_lib \ 299 test_fs_test_lib \
300 test_fs_meta_data \
297 test_gnunet_service_fs_migration \ 301 test_gnunet_service_fs_migration \
298 test_gnunet_service_fs_p2p \ 302 test_gnunet_service_fs_p2p \
299 test_gnunet_service_fs_p2p_cadet \ 303 test_gnunet_service_fs_p2p_cadet \
@@ -446,6 +450,13 @@ test_fs_unindex_persistence_LDADD = \
446 libgnunetfs.la \ 450 libgnunetfs.la \
447 $(top_builddir)/src/util/libgnunetutil.la 451 $(top_builddir)/src/util/libgnunetutil.la
448 452
453test_fs_meta_data_SOURCES = \
454 test_fs_meta_data.c
455test_fs_meta_data_LDADD = \
456 libgnunetfs.la \
457 $(top_builddir)/src/util/libgnunetutil.la
458
459
449test_fs_uri_SOURCES = \ 460test_fs_uri_SOURCES = \
450 test_fs_uri.c 461 test_fs_uri.c
451test_fs_uri_LDADD = \ 462test_fs_uri_LDADD = \
@@ -520,7 +531,6 @@ perf_gnunet_service_fs_p2p_respect_LDADD = \
520 libgnunetfs.la \ 531 libgnunetfs.la \
521 $(top_builddir)/src/util/libgnunetutil.la 532 $(top_builddir)/src/util/libgnunetutil.la
522 533
523
524test_gnunet_fs_psd.py: test_gnunet_fs_psd.py.in Makefile 534test_gnunet_fs_psd.py: test_gnunet_fs_psd.py.in Makefile
525 $(AWK) -v bdir="$(bindir)" -v py="$(PYTHON)" -v awkay="$(AWK_BINARY)" -v pfx="$(prefix)" -v prl="$(PERL)" -v sysconfdirectory="$(sysconfdir)" -v pkgdatadirectory="$(pkgdatadir)" -f $(top_srcdir)/bin/dosubst.awk < $(srcdir)/test_gnunet_fs_psd.py.in > test_gnunet_fs_psd.py 535 $(AWK) -v bdir="$(bindir)" -v py="$(PYTHON)" -v awkay="$(AWK_BINARY)" -v pfx="$(prefix)" -v prl="$(PERL)" -v sysconfdirectory="$(sysconfdir)" -v pkgdatadirectory="$(pkgdatadir)" -f $(top_srcdir)/bin/dosubst.awk < $(srcdir)/test_gnunet_fs_psd.py.in > test_gnunet_fs_psd.py
526 chmod +x test_gnunet_fs_psd.py 536 chmod +x test_gnunet_fs_psd.py