aboutsummaryrefslogtreecommitdiff
path: root/src/gns/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/gns/Makefile.am')
-rw-r--r--src/gns/Makefile.am303
1 files changed, 0 insertions, 303 deletions
diff --git a/src/gns/Makefile.am b/src/gns/Makefile.am
deleted file mode 100644
index 1380cba10..000000000
--- a/src/gns/Makefile.am
+++ /dev/null
@@ -1,303 +0,0 @@
1# This Makefile.am is in the public domain
2AM_CPPFLAGS = -I$(top_srcdir)/src/include
3
4if HAVE_GLIBCNSS
5NSS_SUBDIR = nss
6endif
7
8SUBDIRS = . $(NSS_SUBDIR)
9
10pkgdata_DATA = \
11 gnunet-gns-proxy-ca.template
12
13if HAVE_LIBIDN
14 LIBIDN= -lidn
15else
16 LIBIDN=
17endif
18
19if HAVE_LIBIDN2
20 LIBIDN2= -lidn2
21else
22 LIBIDN2=
23endif
24
25EXTRA_DIST = \
26 test_gns_defaults.conf \
27 test_gns_lookup.conf \
28 test_gns_proxy.conf \
29 test_gns_simple_lookup.conf \
30 openssl.cnf \
31 gnunet-gns-proxy-setup-ca.in \
32 zonefiles/J7POEUT41A8PBFS7KVVDRF88GBOU4HK8PSU5QKVLVE3R9T91E99G.zkey \
33 zonefiles/OEFL7A4VEF1B40QLEMTG5D8G1CN6EN16QUSG5R2DT71GRJN34LSG.zkey \
34 zonefiles/test_zonekey \
35 $(check_SCRIPTS) \
36 $(pkgdata_DATA) \
37 test_gnunet_gns.sh.in
38
39USE_VPN = $(top_builddir)/src/vpn/libgnunetvpn.la
40
41if USE_COVERAGE
42 AM_CFLAGS = --coverage -O0
43endif
44
45pkgcfgdir = $(pkgdatadir)/config.d/
46
47libexecdir= $(pkglibdir)/libexec/
48
49plugindir = $(libdir)/gnunet
50
51pkgcfg_DATA = \
52 gns.conf
53
54lib_LTLIBRARIES = \
55 libgnunetgns.la
56
57
58if HAVE_GNUTLS
59if HAVE_LIBGNURL
60 DO_PROXY=gnunet-gns-proxy
61LIB_GNURL=@LIBGNURL@
62CPP_GNURL=@LIBGNURL_CPPFLAGS@
63else
64if HAVE_LIBCURL
65 DO_PROXY=gnunet-gns-proxy
66LIB_GNURL=@LIBCURL@
67CPP_GNURL=@LIBCURL_CPPFLAGS@
68endif
69endif
70endif
71
72libexec_PROGRAMS = \
73 gnunet-service-gns \
74 gnunet-dns2gns \
75 $(DO_PROXY)
76
77bin_PROGRAMS = \
78 gnunet-gns
79
80noinst_PROGRAMS = \
81 gnunet-gns-benchmark
82
83if HAVE_PDFLATEX
84bin_PROGRAMS += gnunet-bcd
85endif
86
87REST_PLUGIN = libgnunet_plugin_rest_gns.la
88
89plugin_LTLIBRARIES = \
90 libgnunet_plugin_block_gns.la \
91 libgnunet_plugin_gnsrecord_gns.la \
92 $(REST_PLUGIN)
93
94
95bin_SCRIPTS = \
96 gnunet-gns-proxy-setup-ca
97
98gnunet-gns-proxy-setup-ca: gnunet-gns-proxy-setup-ca.in Makefile
99 $(AWK) -v bdir="$(bindir)" -v py="$(PYTHON)" -v awkay="$(AWK_BINARY)" -v pfx="$(prefix)" -v prl="$(PERL)" -v sysconfdirectory="$(sysconfdir)" -v pkgdatadirectory="$(pkgdatadir)" -f $(top_srcdir)/bin/dosubst.awk < $(srcdir)/gnunet-gns-proxy-setup-ca.in > gnunet-gns-proxy-setup-ca
100 @chmod +x gnunet-gns-proxy-setup-ca
101
102test_gnunet_gns.sh: test_gnunet_gns.sh.in Makefile
103 $(AWK) -v bdir="$(bindir)" -v py="$(PYTHON)" -v awkay="$(AWK_BINARY)" -v pfx="$(prefix)" -v prl="$(PERL)" -v sysconfdirectory="$(sysconfdir)" -v pkgdatadirectory="$(pkgdatadir)" -f $(top_srcdir)/bin/dosubst.awk < $(srcdir)/test_gnunet_gns.sh.in > test_gnunet_gns.sh
104 @chmod +x test_gnunet_gns.sh
105
106CLEANFILES = test_gnunet_gns.sh
107
108libgnunet_plugin_rest_gns_la_SOURCES = \
109 plugin_rest_gns.c
110libgnunet_plugin_rest_gns_la_LIBADD = \
111 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
112 $(top_builddir)/src/gnsrecord/libgnunetgnsrecordjson.la \
113 libgnunetgns.la \
114 $(top_builddir)/src/rest/libgnunetrest.la \
115 $(top_builddir)/src/identity/libgnunetidentity.la \
116 $(top_builddir)/src/json/libgnunetjson.la \
117 $(top_builddir)/src/util/libgnunetutil.la $(XLIBS) \
118 $(LTLIBINTL) -ljansson $(MHD_LIBS)
119libgnunet_plugin_rest_gns_la_LDFLAGS = \
120 $(GN_PLUGIN_LDFLAGS)
121libgnunet_plugin_rest_gns_la_CFLAGS = $(MHD_CFLAGS) $(AM_CFLAGS)
122
123
124libgnunet_plugin_gnsrecord_gns_la_SOURCES = \
125 plugin_gnsrecord_gns.c
126libgnunet_plugin_gnsrecord_gns_la_LIBADD = \
127 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
128 $(top_builddir)/src/identity/libgnunetidentity.la \
129 $(top_builddir)/src/util/libgnunetutil.la \
130 $(LTLIBINTL)
131libgnunet_plugin_gnsrecord_gns_la_LDFLAGS = \
132 $(GN_PLUGIN_LDFLAGS)
133
134
135gnunet_gns_SOURCES = \
136 gnunet-gns.c
137gnunet_gns_LDADD = \
138 libgnunetgns.la \
139 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
140 $(top_builddir)/src/identity/libgnunetidentity.la \
141 $(top_builddir)/src/util/libgnunetutil.la \
142 $(LIBIDN) $(LIBIDN2) \
143 $(GN_LIBINTL)
144
145gnunet_gns_benchmark_SOURCES = \
146 gnunet-gns-benchmark.c
147gnunet_gns_benchmark_LDADD = \
148 libgnunetgns.la \
149 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
150 $(top_builddir)/src/identity/libgnunetidentity.la \
151 $(top_builddir)/src/util/libgnunetutil.la \
152 $(GN_LIBINTL)
153
154
155gnunet_bcd_SOURCES = \
156 gnunet-bcd.c
157gnunet_bcd_LDADD = \
158 $(top_builddir)/src/util/libgnunetutil.la \
159 $(top_builddir)/src/identity/libgnunetidentity.la \
160 $(GN_LIBINTL) $(MHD_LIBS)
161gnunet_bcd_CFLAGS = $(MHD_CFLAGS) $(AM_CFLAGS)
162
163
164gnunet_dns2gns_SOURCES = \
165 gnunet-dns2gns.c
166gnunet_dns2gns_LDADD = \
167 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
168 libgnunetgns.la \
169 $(top_builddir)/src/util/libgnunetutil.la \
170 $(top_builddir)/src/identity/libgnunetidentity.la \
171 $(GN_LIBINTL)
172
173if HAVE_SUDO
174SUDO_OR_DOAS_BINARY= $(SUDO_BINARY) -n
175else
176if HAVE_DOAS_BINARY
177SUDO_OR_DOAS_BINARY= $(DOAS_BINARY)
178endif
179endif
180
181if LINUX
182HIJACKBIN = gnunet-dns2gns
183install-exec-hook:
184 $(SUDO_OR_DOAS_BINARY) setcap 'cap_net_bind_service=+ep' $(DESTDIR)$(libexecdir)/gnunet-dns2gns || true
185else
186install-exec-hook:
187endif
188
189gnunet_gns_proxy_SOURCES = \
190 gnunet-gns-proxy.c
191gnunet_gns_proxy_LDADD = $(MHD_LIBS) $(LIB_GNURL) -lgnutls \
192 libgnunetgns.la \
193 $(top_builddir)/src/identity/libgnunetidentity.la \
194 $(top_builddir)/src/util/libgnunetutil.la \
195 $(GN_LIBINTL)
196if HAVE_GNUTLS_DANE
197gnunet_gns_proxy_LDADD += -lgnutls-dane
198endif
199gnunet_gns_proxy_CFLAGS = $(MHD_CFLAGS) $(CPP_GNURL) $(AM_CFLAGS)
200
201test_gns_proxy_SOURCES = \
202 test_gns_proxy.c
203test_gns_proxy_LDADD = $(MHD_LIBS) $(LIB_GNURL) -lgnutls \
204 $(top_builddir)/src/util/libgnunetutil.la \
205 $(GN_LIBINTL)
206test_gns_proxy_CFLAGS = $(MHD_CFLAGS) $(CPP_GNURL) $(AM_CFLAGS)
207
208#gnunet_gns_import_SOURCES = \
209# gnunet-gns-import.c
210#gnunet_gns_import_LDADD = \
211# $(top_builddir)/src/identity/libgnunetidentity.la \
212# $(top_builddir)/src/namestore/libgnunetnamestore.la \
213# $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
214# $(top_builddir)/src/util/libgnunetutil.la \
215# $(GN_LIBINTL)
216
217
218gnunet_service_gns_SOURCES = \
219 gnunet-service-gns.c gnunet-service-gns.h \
220 gnunet-service-gns_resolver.c gnunet-service-gns_resolver.h \
221 gnunet-service-gns_interceptor.c gnunet-service-gns_interceptor.h
222gnunet_service_gns_LDADD = \
223 -lm \
224 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
225 $(top_builddir)/src/identity/libgnunetidentity.la \
226 $(top_builddir)/src/revocation/libgnunetrevocation.la \
227 $(top_builddir)/src/statistics/libgnunetstatistics.la \
228 $(top_builddir)/src/util/libgnunetutil.la \
229 $(top_builddir)/src/dns/libgnunetdns.la \
230 $(top_builddir)/src/dht/libgnunetdht.la \
231 $(top_builddir)/src/namecache/libgnunetnamecache.la \
232 $(LIBIDN) $(LIBIDN2) \
233 $(USE_VPN) \
234 $(GN_LIBINTL)
235
236
237libgnunetgns_la_SOURCES = \
238 gns_api.c gns_api.h \
239 gns_tld_api.c gns.h
240libgnunetgns_la_LIBADD = \
241 $(top_builddir)/src/util/libgnunetutil.la $(XLIB) \
242 $(top_builddir)/src/identity/libgnunetidentity.la \
243 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la
244libgnunetgns_la_LDFLAGS = \
245 $(GN_LIBINTL) \
246 $(GN_LIB_LDFLAGS)
247
248
249libgnunet_plugin_block_gns_la_SOURCES = \
250 plugin_block_gns.c
251libgnunet_plugin_block_gns_la_LIBADD = \
252 $(top_builddir)/src/util/libgnunetutil.la \
253 $(top_builddir)/src/block/libgnunetblock.la \
254 $(top_builddir)/src/block/libgnunetblockgroup.la \
255 $(top_builddir)/src/identity/libgnunetidentity.la \
256 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la
257libgnunet_plugin_block_gns_la_LDFLAGS = \
258 $(GN_LIBINTL) \
259 $(GN_PLUGIN_LDFLAGS)
260
261if HAVE_GNUTLS
262if HAVE_LIBGNURL
263check_PROGRAMS = \
264 test_gns_proxy
265endif
266endif
267
268check_SCRIPTS = \
269 test_gns_lookup.sh \
270 test_gns_config_lookup.sh \
271 test_gns_ipv6_lookup.sh\
272 test_gns_txt_lookup.sh\
273 test_gns_caa_lookup.sh\
274 test_gns_mx_lookup.sh \
275 test_gns_gns2dns_lookup.sh \
276 test_gns_gns2dns_zkey_lookup.sh \
277 test_gns_gns2dns_cname_lookup.sh \
278 test_gns_dht_lookup.sh\
279 test_gns_delegated_lookup.sh \
280 test_gns_at_lookup.sh\
281 test_gns_zkey_lookup.sh\
282 test_gns_rel_expiration.sh\
283 test_gns_soa_lookup.sh\
284 test_gns_revocation.sh\
285 test_gns_cname_lookup.sh\
286 test_proxy.sh
287
288if HAVE_GNUTLS
289if HAVE_LIBGNURL
290check_SCRIPTS += \
291 test_proxy.sh
292endif
293endif
294check_SCRIPTS += \
295 test_plugin_rest_gns.sh
296
297
298if ENABLE_TEST_RUN
299if HAVE_SQLITE
300 AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME;
301 TESTS = $(check_SCRIPTS)
302endif
303endif