aboutsummaryrefslogtreecommitdiff
path: root/src/gns/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/gns/Makefile.am')
-rw-r--r--src/gns/Makefile.am18
1 files changed, 15 insertions, 3 deletions
diff --git a/src/gns/Makefile.am b/src/gns/Makefile.am
index 1abc57d57..434d50f34 100644
--- a/src/gns/Makefile.am
+++ b/src/gns/Makefile.am
@@ -14,7 +14,8 @@ EXTRA_DIST = \
14 test_gns_simple_lookup.conf \ 14 test_gns_simple_lookup.conf \
15 gns-helper-service-w32.conf \ 15 gns-helper-service-w32.conf \
16 w32nsp.def \ 16 w32nsp.def \
17 gnunet-gns-proxy-setup-ca \ 17 openssl.cnf \
18 gnunet-gns-proxy-setup-ca.in \
18 zonefiles/J7POEUT41A8PBFS7KVVDRF88GBOU4HK8PSU5QKVLVE3R9T91E99G.zkey \ 19 zonefiles/J7POEUT41A8PBFS7KVVDRF88GBOU4HK8PSU5QKVLVE3R9T91E99G.zkey \
19 zonefiles/OEFL7A4VEF1B40QLEMTG5D8G1CN6EN16QUSG5R2DT71GRJN34LSG.zkey \ 20 zonefiles/OEFL7A4VEF1B40QLEMTG5D8G1CN6EN16QUSG5R2DT71GRJN34LSG.zkey \
20 zonefiles/test_zonekey \ 21 zonefiles/test_zonekey \
@@ -79,19 +80,30 @@ bin_PROGRAMS = \
79noinst_PROGRAMS = \ 80noinst_PROGRAMS = \
80 gnunet-gns-benchmark 81 gnunet-gns-benchmark
81 82
83pkgdata_DATA = \
84 openssl.cnf
85
82if HAVE_MHD 86if HAVE_MHD
83if LINUX 87if LINUX
84bin_PROGRAMS += gnunet-bcd 88bin_PROGRAMS += gnunet-bcd
85endif 89endif
86endif 90endif
87 91
88bin_SCRIPTS = gnunet-gns-proxy-setup-ca
89
90plugin_LTLIBRARIES = \ 92plugin_LTLIBRARIES = \
91 libgnunet_plugin_block_gns.la \ 93 libgnunet_plugin_block_gns.la \
92 libgnunet_plugin_gnsrecord_gns.la 94 libgnunet_plugin_gnsrecord_gns.la
93 95
94 96
97bin_SCRIPTS = \
98 gnunet-gns-proxy-setup-ca
99
100# See: https://www.gnu.org/software/automake/manual/html_node/Scripts.html#Scripts
101do_subst = sed -e 's,[@]pkgdatadir[@],$(pkgdatadir),g'
102
103gnunet-gns-proxy-setup-ca: gnunet-gns-proxy-setup-ca.in Makefile
104 $(do_subst) < $(srcdir)/gnunet-gns-proxy-setup-ca.in > gnunet-gns-proxy-setup-ca
105 chmod +x gnunet-gns-proxy-setup-ca
106
95libgnunet_plugin_gnsrecord_gns_la_SOURCES = \ 107libgnunet_plugin_gnsrecord_gns_la_SOURCES = \
96 plugin_gnsrecord_gns.c 108 plugin_gnsrecord_gns.c
97libgnunet_plugin_gnsrecord_gns_la_LIBADD = \ 109libgnunet_plugin_gnsrecord_gns_la_LIBADD = \