aboutsummaryrefslogtreecommitdiff
path: root/src/gns/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/gns/meson.build')
-rw-r--r--src/gns/meson.build48
1 files changed, 48 insertions, 0 deletions
diff --git a/src/gns/meson.build b/src/gns/meson.build
index 6e001cf8b..b82694026 100644
--- a/src/gns/meson.build
+++ b/src/gns/meson.build
@@ -160,3 +160,51 @@ executable ('gnunet-dns2gns',
160if have_nss 160if have_nss
161 subdir('nss') 161 subdir('nss')
162endif 162endif
163
164testgns = [
165 'test_dns2gns',
166 'test_gns_at_lookup',
167 'test_gns_caa_lookup',
168 'test_gns_config_lookup',
169 'test_gns_delegated_lookup',
170 'test_gns_dht_lookup',
171 'test_gns_gns2dns_cname_lookup',
172 'test_gns_gns2dns_lookup',
173 'test_gns_gns2dns_zkey_lookup',
174 'test_gns_ipv6_lookup',
175 'test_gns_lookup',
176 'test_gns_multiple_record_lookup',
177 'test_gns_mx_lookup',
178 'test_gns_quickupdate',
179 'test_gns_redirect_lookup',
180 'test_gns_rel_expiration',
181 'test_gns_revocation',
182 'test_gns_soa_lookup',
183 'test_gns_txt_lookup',
184 'test_gns_zkey_lookup',
185 'test_plugin_rest_gns',
186]
187
188testconfigs = [
189 'test_dns2gns.conf',
190 'test_gns_defaults.conf',
191 'test_gns_lookup.conf',
192 'test_gns_lookup_peer1.conf',
193 'test_gns_lookup_peer2.conf',
194 'test_gns_proxy.conf',
195 'test_gns_simple_lookup.conf'
196]
197
198foreach f : testconfigs
199 configure_file(input: f, output: f, copy: true)
200endforeach
201
202foreach t : testgns
203
204 test_filename = t + '.sh'
205 test_file = configure_file(input : test_filename,
206 output : test_filename,
207 copy: true)
208
209 test(t, test_file, suite: 'gns', workdir: meson.current_build_dir(), is_parallel: false)
210endforeach