aboutsummaryrefslogtreecommitdiff
path: root/src/gnsrecord/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/gnsrecord/Makefile.am')
-rw-r--r--src/gnsrecord/Makefile.am23
1 files changed, 22 insertions, 1 deletions
diff --git a/src/gnsrecord/Makefile.am b/src/gnsrecord/Makefile.am
index 2fb859f39..1f489c8d7 100644
--- a/src/gnsrecord/Makefile.am
+++ b/src/gnsrecord/Makefile.am
@@ -15,6 +15,10 @@ if USE_COVERAGE
15 XLIBS = -lgcov 15 XLIBS = -lgcov
16endif 16endif
17 17
18check_PROGRAMS = \
19 test_gnsrecord_crypto \
20 test_gnsrecord_serialization
21
18if ENABLE_TEST_RUN 22if ENABLE_TEST_RUN
19TESTS = \ 23TESTS = \
20 $(check_PROGRAMS) \ 24 $(check_PROGRAMS) \
@@ -25,7 +29,10 @@ lib_LTLIBRARIES = \
25 libgnunetgnsrecord.la 29 libgnunetgnsrecord.la
26 30
27libgnunetgnsrecord_la_SOURCES = \ 31libgnunetgnsrecord_la_SOURCES = \
28 gnsrecord.c 32 gnsrecord.c \
33 gnsrecord_serialization.c \
34 gnsrecord_crypto.c \
35 gnsrecord_misc.c
29libgnunetgnsrecord_la_LIBADD = \ 36libgnunetgnsrecord_la_LIBADD = \
30 $(top_builddir)/src/dns/libgnunetdnsparser.la \ 37 $(top_builddir)/src/dns/libgnunetdnsparser.la \
31 $(top_builddir)/src/util/libgnunetutil.la \ 38 $(top_builddir)/src/util/libgnunetutil.la \
@@ -52,3 +59,17 @@ libgnunet_plugin_gnsrecord_dns_la_LDFLAGS = \
52EXTRA_DIST = \ 59EXTRA_DIST = \
53 $(check_SCRIPTS) 60 $(check_SCRIPTS)
54 61
62test_gnsrecord_serialization_SOURCES = \
63 test_gnsrecord_serialization.c
64test_gnsrecord_serialization_LDADD = \
65 $(top_builddir)/src/testing/libgnunettesting.la \
66 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
67 $(top_builddir)/src/util/libgnunetutil.la
68
69test_gnsrecord_crypto_SOURCES = \
70 test_gnsrecord_crypto.c
71test_gnsrecord_crypto_LDADD = \
72 $(top_builddir)/src/testing/libgnunettesting.la \
73 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
74 $(top_builddir)/src/util/libgnunetutil.la
75