aboutsummaryrefslogtreecommitdiff
path: root/src/gnsrecord/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/gnsrecord/Makefile.am')
-rw-r--r--src/gnsrecord/Makefile.am129
1 files changed, 0 insertions, 129 deletions
diff --git a/src/gnsrecord/Makefile.am b/src/gnsrecord/Makefile.am
deleted file mode 100644
index 7ef7c327e..000000000
--- a/src/gnsrecord/Makefile.am
+++ /dev/null
@@ -1,129 +0,0 @@
1# This Makefile.am is in the public domain
2AM_CPPFLAGS = -I$(top_srcdir)/src/include ${MHD_CFLAGS}
3
4plugindir = $(libdir)/gnunet
5
6pkgcfgdir= $(pkgdatadir)/config.d/
7
8libexecdir= $(pkglibdir)/libexec/
9
10if USE_COVERAGE
11 AM_CFLAGS = --coverage -O0
12 XLIBS = -lgcov
13endif
14
15noinst_PROGRAMS = \
16 gnunet-gnsrecord-tvg
17
18
19check_PROGRAMS = \
20 test_gnsrecord_crypto \
21 test_gnsrecord_serialization \
22 test_gnsrecord_lsd0001testvectors \
23 test_gnsrecord_block_expiration \
24 perf_gnsrecord_crypto
25
26if ENABLE_TEST_RUN
27AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME;
28TESTS = \
29 $(check_PROGRAMS) \
30 $(check_SCRIPTS)
31endif
32
33lib_LTLIBRARIES = \
34 libgnunetgnsrecord.la \
35 libgnunetgnsrecordjson.la
36
37gnunet_gnsrecord_tvg_SOURCES = \
38 gnunet-gnsrecord-tvg.c \
39 gnsrecord_crypto.h
40gnunet_gnsrecord_tvg_LDADD = \
41 $(top_builddir)/src/util/libgnunetutil.la \
42 $(top_builddir)/src/identity/libgnunetidentity.la \
43 libgnunetgnsrecord.la \
44 $(GN_LIBINTL)
45
46
47libgnunetgnsrecord_la_SOURCES = \
48 gnsrecord.c \
49 gnsrecord_serialization.c \
50 gnsrecord_crypto.c \
51 gnsrecord_misc.c
52libgnunetgnsrecord_la_LIBADD = \
53 $(top_builddir)/src/util/libgnunetutil.la \
54 $(top_builddir)/src/identity/libgnunetidentity.la \
55 $(LIBGCRYPT_LIBS) \
56 -lsodium \
57 $(GN_LIBINTL)
58libgnunetgnsrecord_la_LDFLAGS = \
59 $(GN_LIB_LDFLAGS) \
60 -version-info 0:0:0
61
62libgnunetgnsrecordjson_la_SOURCES = \
63 json_gnsrecord.c
64libgnunetgnsrecordjson_la_LIBADD = \
65 $(top_builddir)/src/util/libgnunetutil.la \
66 $(top_builddir)/src/identity/libgnunetidentity.la \
67 libgnunetgnsrecord.la \
68 -ljansson \
69 $(GN_LIBINTL)
70libgnunetgnsrecordjson_la_LDFLAGS = \
71 $(GN_LIB_LDFLAGS) \
72 -version-info 0:0:0
73
74plugin_LTLIBRARIES = \
75 libgnunet_plugin_gnsrecord_dns.la
76
77
78libgnunet_plugin_gnsrecord_dns_la_SOURCES = \
79 plugin_gnsrecord_dns.c
80libgnunet_plugin_gnsrecord_dns_la_LIBADD = \
81 $(top_builddir)/src/util/libgnunetutil.la \
82 $(LTLIBINTL)
83libgnunet_plugin_gnsrecord_dns_la_LDFLAGS = \
84 $(GN_PLUGIN_LDFLAGS)
85
86
87EXTRA_DIST = \
88 $(check_SCRIPTS)
89
90test_gnsrecord_lsd0001testvectors_SOURCES = \
91 test_gnsrecord_testvectors.c
92test_gnsrecord_lsd0001testvectors_LDADD = \
93 $(top_builddir)/src/testing/libgnunettesting.la \
94 $(top_builddir)/src/identity/libgnunetidentity.la \
95 libgnunetgnsrecord.la \
96 $(top_builddir)/src/util/libgnunetutil.la
97
98
99test_gnsrecord_serialization_SOURCES = \
100 test_gnsrecord_serialization.c
101test_gnsrecord_serialization_LDADD = \
102 $(top_builddir)/src/testing/libgnunettesting.la \
103 libgnunetgnsrecord.la \
104 $(top_builddir)/src/util/libgnunetutil.la
105
106test_gnsrecord_block_expiration_SOURCES = \
107 test_gnsrecord_block_expiration.c
108test_gnsrecord_block_expiration_LDADD = \
109 $(top_builddir)/src/testing/libgnunettesting.la \
110 libgnunetgnsrecord.la \
111 $(top_builddir)/src/util/libgnunetutil.la
112
113
114test_gnsrecord_crypto_SOURCES = \
115 test_gnsrecord_crypto.c
116test_gnsrecord_crypto_LDADD = \
117 $(top_builddir)/src/testing/libgnunettesting.la \
118 $(top_builddir)/src/identity/libgnunetidentity.la \
119 libgnunetgnsrecord.la \
120 $(top_builddir)/src/util/libgnunetutil.la
121
122
123perf_gnsrecord_crypto_SOURCES = \
124 perf_gnsrecord_crypto.c
125perf_gnsrecord_crypto_LDADD = \
126 $(top_builddir)/src/testing/libgnunettesting.la \
127 $(top_builddir)/src/identity/libgnunetidentity.la \
128 libgnunetgnsrecord.la \
129 $(top_builddir)/src/util/libgnunetutil.la