aboutsummaryrefslogtreecommitdiff
path: root/src/hello/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/hello/Makefile.am')
-rw-r--r--src/hello/Makefile.am69
1 files changed, 0 insertions, 69 deletions
diff --git a/src/hello/Makefile.am b/src/hello/Makefile.am
deleted file mode 100644
index c04b85106..000000000
--- a/src/hello/Makefile.am
+++ /dev/null
@@ -1,69 +0,0 @@
1# This Makefile.am is in the public domain
2AM_CPPFLAGS = -I$(top_srcdir)/src/include
3
4if USE_COVERAGE
5 AM_CFLAGS = --coverage -O0
6 XLIB = -lgcov
7endif
8
9lib_LTLIBRARIES = libgnunethello.la
10
11libgnunethello_la_SOURCES = \
12 hello.c \
13 address.c \
14 hello-ng.c \
15 hello-uri.c
16libgnunethello_la_LIBADD = \
17 $(top_builddir)/src/util/libgnunetutil.la $(XLIB) \
18 $(LTLIBINTL)
19libgnunethello_la_LDFLAGS = \
20 $(GN_LIB_LDFLAGS) \
21 -version-info 1:0:1
22
23noinst_PROGRAMS = \
24 gnunet-hello
25
26check_PROGRAMS = \
27 test_hello \
28 test_hello-uri \
29 test_friend_hello \
30 test_hello-ng
31
32if ENABLE_TEST_RUN
33AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME;
34TESTS = $(check_PROGRAMS)
35endif
36
37test_hello_SOURCES = \
38 test_hello.c
39test_hello_LDADD = \
40 libgnunethello.la \
41 $(top_builddir)/src/util/libgnunetutil.la
42
43test_hello_ng_SOURCES = \
44 test_hello-ng.c
45test_hello_ng_LDADD = \
46 libgnunethello.la \
47 $(top_builddir)/src/util/libgnunetutil.la
48
49test_hello_uri_SOURCES = \
50 test_hello-uri.c
51test_hello_uri_LDADD = \
52 libgnunethello.la \
53 $(top_builddir)/src/util/libgnunetutil.la \
54 -lgcrypt
55
56
57test_friend_hello_SOURCES = \
58 test_friend_hello.c
59test_friend_hello_LDADD = \
60 libgnunethello.la \
61 $(top_builddir)/src/util/libgnunetutil.la
62
63gnunet_hello_SOURCES = \
64 gnunet-hello.c
65gnunet_hello_LDADD = \
66 libgnunethello.la \
67 $(top_builddir)/src/util/libgnunetutil.la
68gnunet_hello_LDFLAGS = \
69 $(GN_LIBINTL)