aboutsummaryrefslogtreecommitdiff
path: root/src/hello/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/hello/meson.build')
-rw-r--r--src/hello/meson.build18
1 files changed, 8 insertions, 10 deletions
diff --git a/src/hello/meson.build b/src/hello/meson.build
index 04d5a6bef..c0df8b76c 100644
--- a/src/hello/meson.build
+++ b/src/hello/meson.build
@@ -1,11 +1,8 @@
1libgnunethello_src = ['hello.c', 1libgnunethello_src = [#'hello.c',
2 'address.c', 2 'address.c',
3 'hello-ng.c', 3 'hello-ng.c',
4 'hello-uri.c'] 4 'hello-uri.c']
5 5
6gnunethello_src = ['gnunet-hello.c']
7
8
9if get_option('monolith') 6if get_option('monolith')
10 foreach p : libgnunethello_src 7 foreach p : libgnunethello_src
11 gnunet_src += 'hello/' + p 8 gnunet_src += 'hello/' + p
@@ -26,10 +23,11 @@ pkg.generate(libgnunethello, url: 'https://www.gnunet.org',
26 description : 'Helper library for handling GNUnet HELLO messages') 23 description : 'Helper library for handling GNUnet HELLO messages')
27 24
28 25
29executable ('gnunet-hello', 26# TNG
30 gnunethello_src, 27#executable ('gnunet-hello',
31 dependencies: [libgnunethello_dep, libgnunetutil_dep], 28# ['gnunet-hello.c'],
32 include_directories: [incdir, configuration_inc], 29# dependencies: [libgnunethello_dep, libgnunetutil_dep],
33 install: true, 30# include_directories: [incdir, configuration_inc],
34 install_dir: get_option('bindir')) 31# install: true,
32# install_dir: get_option('bindir'))
35 33