aboutsummaryrefslogtreecommitdiff
path: root/src/hello/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/hello/meson.build')
-rw-r--r--src/hello/meson.build23
1 files changed, 23 insertions, 0 deletions
diff --git a/src/hello/meson.build b/src/hello/meson.build
new file mode 100644
index 000000000..1e5fc4ff6
--- /dev/null
+++ b/src/hello/meson.build
@@ -0,0 +1,23 @@
1libgnunethello_src = ['hello.c',
2 'address.c',
3 'hello-ng.c',
4 'hello-uri.c']
5
6gnunethello_src = ['gnunet-hello.c']
7
8
9if gnunet_monolith == false
10 libgnunethello = library('gnunethello',
11 libgnunethello_src,
12 dependencies: libgnunetutil_dep,
13 include_directories: [incdir, configuration_inc])
14 libgnunethello_dep = declare_dependency(link_with : libgnunethello)
15 executable ('gnunet-hello',
16 gnunethello_src,
17 dependencies: [libgnunethello_dep, libgnunetutil_dep],
18 include_directories: [incdir, configuration_inc])
19else
20 foreach p : libgnunethello_src + gnunethello_src
21 gnunet_src += 'hello/' + p
22 endforeach
23endif