aboutsummaryrefslogtreecommitdiff
path: root/src/hostlist/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/hostlist/Makefile.am')
-rw-r--r--src/hostlist/Makefile.am83
1 files changed, 0 insertions, 83 deletions
diff --git a/src/hostlist/Makefile.am b/src/hostlist/Makefile.am
deleted file mode 100644
index 77c9eb1de..000000000
--- a/src/hostlist/Makefile.am
+++ /dev/null
@@ -1,83 +0,0 @@
1# This Makefile.am is in the public domain
2AM_CPPFLAGS = -I$(top_srcdir)/src/include
3
4pkgcfgdir= $(pkgdatadir)/config.d/
5
6libexecdir= $(pkglibdir)/libexec/
7
8
9if USE_COVERAGE
10 AM_CFLAGS = --coverage -O0
11endif
12
13 HOSTLIST_SERVER_SOURCES = \
14 gnunet-daemon-hostlist_server.c gnunet-daemon-hostlist_server.h
15 GN_LIBMHD = $(MHD_LIBS)
16 GN_CPPMHD = $(MHD_CFLAGS)
17
18libexec_PROGRAMS = \
19 gnunet-daemon-hostlist
20dist_pkgcfg_DATA = \
21 hostlist.conf
22
23gnunet_daemon_hostlist_SOURCES = \
24 gnunet-daemon-hostlist.c gnunet-daemon-hostlist.h \
25 gnunet-daemon-hostlist_client.c gnunet-daemon-hostlist_client.h \
26 $(HOSTLIST_SERVER_SOURCES)
27
28gnunet_daemon_hostlist_LDADD = \
29 $(top_builddir)/src/core/libgnunetcore.la \
30 $(top_builddir)/src/hello/libgnunethello.la \
31 $(top_builddir)/src/peerinfo/libgnunetpeerinfo.la \
32 $(top_builddir)/src/statistics/libgnunetstatistics.la \
33 $(top_builddir)/src/transport/libgnunettransport.la \
34 $(top_builddir)/src/util/libgnunetutil.la \
35 $(GN_LIBMHD) \
36 @LIBCURL@ \
37 $(GN_LIBINTL)
38
39gnunet_daemon_hostlist_CFLAGS = \
40 $(GN_CPPMHD) \
41 @LIBCURL_CPPFLAGS@ \
42 $(AM_CFLAGS)
43
44check_PROGRAMS = \
45 test_gnunet_daemon_hostlist \
46 test_gnunet_daemon_hostlist_reconnect \
47 test_gnunet_daemon_hostlist_learning
48
49if ENABLE_TEST_RUN
50AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME;
51TESTS = \
52 $(check_PROGRAMS)
53endif
54
55test_gnunet_daemon_hostlist_SOURCES = \
56 test_gnunet_daemon_hostlist.c
57test_gnunet_daemon_hostlist_LDADD = \
58 $(top_builddir)/src/transport/libgnunettransport.la \
59 $(top_builddir)/src/util/libgnunetutil.la
60
61test_gnunet_daemon_hostlist_reconnect_SOURCES = \
62 test_gnunet_daemon_hostlist_reconnect.c
63test_gnunet_daemon_hostlist_reconnect_LDADD = \
64 $(top_builddir)/src/transport/libgnunettransport.la \
65 $(top_builddir)/src/util/libgnunetutil.la
66
67test_gnunet_daemon_hostlist_learning_SOURCES = \
68 test_gnunet_daemon_hostlist_learning.c
69test_gnunet_daemon_hostlist_learning_LDADD = \
70 $(top_builddir)/src/transport/libgnunettransport.la \
71 $(top_builddir)/src/core/libgnunetcore.la \
72 $(top_builddir)/src/statistics/libgnunetstatistics.la \
73 $(top_builddir)/src/util/libgnunetutil.la
74
75EXTRA_DIST = \
76 test_hostlist_defaults.conf \
77 test_gnunet_daemon_hostlist_data.conf \
78 test_gnunet_daemon_hostlist_peer1.conf \
79 test_gnunet_daemon_hostlist_peer2.conf \
80 test_learning_adv_peer.conf \
81 test_learning_learn_peer.conf \
82 test_learning_learn_peer2.conf \
83 learning_data.conf