aboutsummaryrefslogtreecommitdiff
path: root/src/hostlist/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/hostlist/Makefile.am')
-rw-r--r--src/hostlist/Makefile.am4
1 files changed, 0 insertions, 4 deletions
diff --git a/src/hostlist/Makefile.am b/src/hostlist/Makefile.am
index a8621a2b0..3b534de70 100644
--- a/src/hostlist/Makefile.am
+++ b/src/hostlist/Makefile.am
@@ -10,12 +10,10 @@ if USE_COVERAGE
10 AM_CFLAGS = --coverage -O0 10 AM_CFLAGS = --coverage -O0
11endif 11endif
12 12
13if HAVE_MHD
14 HOSTLIST_SERVER_SOURCES = \ 13 HOSTLIST_SERVER_SOURCES = \
15 gnunet-daemon-hostlist_server.c gnunet-daemon-hostlist_server.h 14 gnunet-daemon-hostlist_server.c gnunet-daemon-hostlist_server.h
16 GN_LIBMHD = $(MHD_LIBS) 15 GN_LIBMHD = $(MHD_LIBS)
17 GN_CPPMHD = $(MHD_CFLAGS) 16 GN_CPPMHD = $(MHD_CFLAGS)
18endif
19 17
20if HAVE_LIBGNURL 18if HAVE_LIBGNURL
21libexec_PROGRAMS = \ 19libexec_PROGRAMS = \
@@ -70,13 +68,11 @@ check_PROGRAMS = \
70endif 68endif
71endif 69endif
72 70
73if HAVE_MHD
74if ENABLE_TEST_RUN 71if ENABLE_TEST_RUN
75AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME; 72AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME;
76TESTS = \ 73TESTS = \
77 $(check_PROGRAMS) 74 $(check_PROGRAMS)
78endif 75endif
79endif
80 76
81test_gnunet_daemon_hostlist_SOURCES = \ 77test_gnunet_daemon_hostlist_SOURCES = \
82 test_gnunet_daemon_hostlist.c 78 test_gnunet_daemon_hostlist.c