aboutsummaryrefslogtreecommitdiff
path: root/src/identity-provider/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/identity-provider/Makefile.am')
-rw-r--r--src/identity-provider/Makefile.am13
1 files changed, 11 insertions, 2 deletions
diff --git a/src/identity-provider/Makefile.am b/src/identity-provider/Makefile.am
index 4f5738692..ab0c2f67e 100644
--- a/src/identity-provider/Makefile.am
+++ b/src/identity-provider/Makefile.am
@@ -22,7 +22,8 @@ pkgcfg_DATA = \
22lib_LTLIBRARIES = \ 22lib_LTLIBRARIES = \
23 libgnunetidentityprovider.la 23 libgnunetidentityprovider.la
24plugin_LTLIBRARIES = \ 24plugin_LTLIBRARIES = \
25 libgnunet_plugin_rest_identity_provider.la 25 libgnunet_plugin_rest_identity_provider.la \
26 libgnunet_plugin_gnsrecord_identity_provider.la
26 27
27bin_PROGRAMS = \ 28bin_PROGRAMS = \
28 gnunet-identity-token \ 29 gnunet-identity-token \
@@ -31,6 +32,15 @@ bin_PROGRAMS = \
31libexec_PROGRAMS = \ 32libexec_PROGRAMS = \
32 gnunet-service-identity-provider 33 gnunet-service-identity-provider
33 34
35libgnunet_plugin_gnsrecord_identity_provider_la_SOURCES = \
36 plugin_gnsrecord_identity_provider.c
37libgnunet_plugin_gnsrecord_identity_provider_la_LIBADD = \
38 $(top_builddir)/src/util/libgnunetutil.la \
39 $(LTLIBINTL)
40libgnunet_plugin_gnsrecord_identity_provider_la_LDFLAGS = \
41 $(GN_PLUGIN_LDFLAGS)
42
43
34gnunet_service_identity_provider_SOURCES = \ 44gnunet_service_identity_provider_SOURCES = \
35 gnunet-service-identity-provider.c \ 45 gnunet-service-identity-provider.c \
36 identity_token.c 46 identity_token.c
@@ -68,7 +78,6 @@ libgnunet_plugin_rest_identity_provider_la_LIBADD = \
68libgnunet_plugin_rest_identity_provider_la_LDFLAGS = \ 78libgnunet_plugin_rest_identity_provider_la_LDFLAGS = \
69 $(GN_PLUGIN_LDFLAGS) 79 $(GN_PLUGIN_LDFLAGS)
70 80
71
72gnunet_idp_SOURCES = \ 81gnunet_idp_SOURCES = \
73 gnunet-idp.c 82 gnunet-idp.c
74gnunet_idp_LDADD = \ 83gnunet_idp_LDADD = \