aboutsummaryrefslogtreecommitdiff
path: root/src/identity-token/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/identity-token/Makefile.am')
-rw-r--r--src/identity-token/Makefile.am17
1 files changed, 11 insertions, 6 deletions
diff --git a/src/identity-token/Makefile.am b/src/identity-token/Makefile.am
index 974de98d9..a9338ba59 100644
--- a/src/identity-token/Makefile.am
+++ b/src/identity-token/Makefile.am
@@ -19,10 +19,10 @@ libexecdir= $(pkglibdir)/libexec/
19pkgcfg_DATA = \ 19pkgcfg_DATA = \
20 identity-token.conf 20 identity-token.conf
21 21
22if HAVE_REST
23plugin_LTLIBRARIES = \ 22plugin_LTLIBRARIES = \
24 libgnunet_plugin_rest_identity_token.la 23 libgnunet_plugin_rest_identity_token.la
25endif 24lib_LTLIBRARIES = \
25 libgnunetidentityprovider.la
26 26
27bin_PROGRAMS = \ 27bin_PROGRAMS = \
28 gnunet-identity-token 28 gnunet-identity-token
@@ -31,9 +31,9 @@ libexec_PROGRAMS = \
31 gnunet-service-identity-token 31 gnunet-service-identity-token
32 32
33gnunet_service_identity_token_SOURCES = \ 33gnunet_service_identity_token_SOURCES = \
34 gnunet-service-identity-token.c \ 34 gnunet-service-identity-token.c
35 identity-token.c
36gnunet_service_identity_token_LDADD = \ 35gnunet_service_identity_token_LDADD = \
36 libgnunetidentityprovider.la \
37 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \ 37 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
38 $(top_builddir)/src/util/libgnunetutil.la \ 38 $(top_builddir)/src/util/libgnunetutil.la \
39 $(top_builddir)/src/namestore/libgnunetnamestore.la \ 39 $(top_builddir)/src/namestore/libgnunetnamestore.la \
@@ -41,9 +41,14 @@ gnunet_service_identity_token_LDADD = \
41 $(GN_LIBINTL) \ 41 $(GN_LIBINTL) \
42 -ljansson 42 -ljansson
43 43
44libgnunetidentityprovider_la_SOURCES = \
45 identity-token.c
46libgnunetidentityprovider_la_LIBADD = \
47 $(top_builddir)/src/util/libgnunetutil.la $(XLIBS) \
48 $(LTLIBINTL) -ljansson
49
44libgnunet_plugin_rest_identity_token_la_SOURCES = \ 50libgnunet_plugin_rest_identity_token_la_SOURCES = \
45 plugin_rest_identity_token.c \ 51 plugin_rest_identity_token.c
46 identity-token.c
47libgnunet_plugin_rest_identity_token_la_LIBADD = \ 52libgnunet_plugin_rest_identity_token_la_LIBADD = \
48 $(top_builddir)/src/identity/libgnunetidentity.la \ 53 $(top_builddir)/src/identity/libgnunetidentity.la \
49 $(top_builddir)/src/rest/libgnunetrest.la \ 54 $(top_builddir)/src/rest/libgnunetrest.la \