aboutsummaryrefslogtreecommitdiff
path: root/src/identity/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/identity/Makefile.am')
-rw-r--r--src/identity/Makefile.am99
1 files changed, 0 insertions, 99 deletions
diff --git a/src/identity/Makefile.am b/src/identity/Makefile.am
deleted file mode 100644
index e806f0059..000000000
--- a/src/identity/Makefile.am
+++ /dev/null
@@ -1,99 +0,0 @@
1# This Makefile.am is in the public domain
2AM_CPPFLAGS = -I$(top_srcdir)/src/include
3
4plugindir = $(libdir)/gnunet
5
6if USE_COVERAGE
7 AM_CFLAGS = --coverage -O0
8 XLIB = -lgcov
9endif
10
11plugin_LTLIBRARIES = libgnunet_plugin_rest_identity.la
12
13pkgcfgdir= $(pkgdatadir)/config.d/
14
15libexecdir= $(pkglibdir)/libexec/
16
17pkgcfg_DATA = \
18 identity.conf
19
20lib_LTLIBRARIES = \
21 libgnunetidentity.la
22
23
24libgnunet_plugin_rest_identity_la_SOURCES = \
25 plugin_rest_identity.c
26libgnunet_plugin_rest_identity_la_LIBADD = \
27 libgnunetidentity.la \
28 $(top_builddir)/src/rest/libgnunetrest.la \
29 $(top_builddir)/src/util/libgnunetutil.la $(XLIBS) \
30 $(LTLIBINTL) -ljansson $(MHD_LIBS)
31libgnunet_plugin_rest_identity_la_LDFLAGS = \
32 $(GN_PLUGIN_LDFLAGS)
33libgnunet_plugin_rest_identity_la_CFLAGS = $(MHD_CFLAGS) $(AM_CFLAGS)
34
35
36libgnunetidentity_la_SOURCES = \
37 identity_api.c \
38 identity_api_lookup.c \
39 identity_api_suffix_lookup.c \
40 identity.h
41libgnunetidentity_la_LIBADD = \
42 $(top_builddir)/src/util/libgnunetutil.la \
43 $(GN_LIBINTL) $(XLIB)
44libgnunetidentity_la_LDFLAGS = \
45 $(GN_LIB_LDFLAGS) \
46 -version-info 1:0:0
47
48bin_PROGRAMS = \
49 gnunet-identity
50
51libexec_PROGRAMS = \
52 gnunet-service-identity
53
54gnunet_service_identity_SOURCES = \
55 gnunet-service-identity.c
56gnunet_service_identity_LDADD = \
57 $(top_builddir)/src/statistics/libgnunetstatistics.la \
58 $(top_builddir)/src/util/libgnunetutil.la \
59 $(GN_LIBINTL)
60
61
62gnunet_identity_SOURCES = \
63 gnunet-identity.c
64gnunet_identity_LDADD = \
65 libgnunetidentity.la \
66 $(top_builddir)/src/statistics/libgnunetstatistics.la \
67 $(top_builddir)/src/util/libgnunetutil.la \
68 $(GN_LIBINTL)
69
70if HAVE_TESTING
71check_PROGRAMS = \
72 test_identity \
73 test_identity_defaults
74endif
75
76if ENABLE_TEST_RUN
77AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME;
78TESTS = $(check_PROGRAMS)
79endif
80
81
82test_identity_SOURCES = \
83 test_identity.c
84test_identity_LDADD = \
85 libgnunetidentity.la \
86 $(top_builddir)/src/testing/libgnunettesting.la \
87 $(top_builddir)/src/util/libgnunetutil.la
88
89test_identity_defaults_SOURCES = \
90 test_identity_defaults.c
91test_identity_defaults_LDADD = \
92 libgnunetidentity.la \
93 $(top_builddir)/src/testing/libgnunettesting.la \
94 $(top_builddir)/src/util/libgnunetutil.la
95
96EXTRA_DIST = \
97 test_identity.conf
98
99