aboutsummaryrefslogtreecommitdiff
path: root/src/identity/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/identity/Makefile.am')
-rw-r--r--src/identity/Makefile.am20
1 files changed, 6 insertions, 14 deletions
diff --git a/src/identity/Makefile.am b/src/identity/Makefile.am
index 5a2110974..12d3906a8 100644
--- a/src/identity/Makefile.am
+++ b/src/identity/Makefile.am
@@ -49,10 +49,10 @@ bin_PROGRAMS = \
49 gnunet-identity 49 gnunet-identity
50 50
51libexec_PROGRAMS = \ 51libexec_PROGRAMS = \
52 gnunet-service-identity 52 gnunet-service-identity
53 53
54gnunet_service_identity_SOURCES = \ 54gnunet_service_identity_SOURCES = \
55 gnunet-service-identity.c 55 gnunet-service-identity.c
56gnunet_service_identity_LDADD = \ 56gnunet_service_identity_LDADD = \
57 $(top_builddir)/src/statistics/libgnunetstatistics.la \ 57 $(top_builddir)/src/statistics/libgnunetstatistics.la \
58 $(top_builddir)/src/util/libgnunetutil.la \ 58 $(top_builddir)/src/util/libgnunetutil.la \
@@ -60,7 +60,7 @@ gnunet_service_identity_LDADD = \
60 60
61 61
62gnunet_identity_SOURCES = \ 62gnunet_identity_SOURCES = \
63 gnunet-identity.c 63 gnunet-identity.c
64gnunet_identity_LDADD = \ 64gnunet_identity_LDADD = \
65 libgnunetidentity.la \ 65 libgnunetidentity.la \
66 $(top_builddir)/src/statistics/libgnunetstatistics.la \ 66 $(top_builddir)/src/statistics/libgnunetstatistics.la \
@@ -68,8 +68,7 @@ gnunet_identity_LDADD = \
68 $(GN_LIBINTL) 68 $(GN_LIBINTL)
69 69
70check_PROGRAMS = \ 70check_PROGRAMS = \
71 test_identity \ 71 test_identity
72 test_identity_defaults
73 72
74check_SCRIPTS = \ 73check_SCRIPTS = \
75 test_identity_messages.sh 74 test_identity_messages.sh
@@ -85,17 +84,10 @@ test_identity_SOURCES = \
85test_identity_LDADD = \ 84test_identity_LDADD = \
86 libgnunetidentity.la \ 85 libgnunetidentity.la \
87 $(top_builddir)/src/testing/libgnunettesting.la \ 86 $(top_builddir)/src/testing/libgnunettesting.la \
88 $(top_builddir)/src/util/libgnunetutil.la 87 $(top_builddir)/src/util/libgnunetutil.la
89
90test_identity_defaults_SOURCES = \
91 test_identity_defaults.c
92test_identity_defaults_LDADD = \
93 libgnunetidentity.la \
94 $(top_builddir)/src/testing/libgnunettesting.la \
95 $(top_builddir)/src/util/libgnunetutil.la
96 88
97EXTRA_DIST = \ 89EXTRA_DIST = \
98 test_identity.conf \ 90 test_identity.conf \
99 test_identity_messages.sh 91 test_identity_messages.sh
100 92
101 93