aboutsummaryrefslogtreecommitdiff
path: root/src/identity/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/identity/Makefile.am')
-rw-r--r--src/identity/Makefile.am95
1 files changed, 0 insertions, 95 deletions
diff --git a/src/identity/Makefile.am b/src/identity/Makefile.am
deleted file mode 100644
index 06cfff965..000000000
--- a/src/identity/Makefile.am
+++ /dev/null
@@ -1,95 +0,0 @@
1# This Makefile.am is in the public domain
2AM_CPPFLAGS = -I$(top_srcdir)/src/include
3
4plugindir = $(libdir)/gnunet
5
6if USE_COVERAGE
7 AM_CFLAGS = --coverage -O0
8 XLIB = -lgcov
9endif
10
11plugin_LTLIBRARIES = libgnunet_plugin_rest_identity.la
12
13pkgcfgdir= $(pkgdatadir)/config.d/
14
15libexecdir= $(pkglibdir)/libexec/
16
17pkgcfg_DATA = \
18 identity.conf
19
20lib_LTLIBRARIES = \
21 libgnunetidentity.la
22
23
24libgnunet_plugin_rest_identity_la_SOURCES = \
25 plugin_rest_identity.c
26libgnunet_plugin_rest_identity_la_LIBADD = \
27 libgnunetidentity.la \
28 $(top_builddir)/src/rest/libgnunetrest.la \
29 $(top_builddir)/src/util/libgnunetutil.la $(XLIBS) \
30 $(LTLIBINTL) -ljansson $(MHD_LIBS)
31libgnunet_plugin_rest_identity_la_LDFLAGS = \
32 $(GN_PLUGIN_LDFLAGS)
33libgnunet_plugin_rest_identity_la_CFLAGS = $(MHD_CFLAGS) $(AM_CFLAGS)
34
35
36libgnunetidentity_la_SOURCES = \
37 identity_api.c \
38 identity_api_lookup.c \
39 identity_api_suffix_lookup.c \
40 identity.h
41libgnunetidentity_la_LIBADD = \
42 $(top_builddir)/src/util/libgnunetutil.la \
43 $(GN_LIBINTL) $(XLIB)
44libgnunetidentity_la_LDFLAGS = \
45 $(GN_LIB_LDFLAGS) \
46 -lsodium \
47 -version-info 1:0:0
48
49bin_PROGRAMS = \
50 gnunet-identity
51
52libexec_PROGRAMS = \
53 gnunet-service-identity
54
55gnunet_service_identity_SOURCES = \
56 gnunet-service-identity.c
57gnunet_service_identity_LDADD = \
58 libgnunetidentity.la \
59 $(top_builddir)/src/statistics/libgnunetstatistics.la \
60 $(top_builddir)/src/util/libgnunetutil.la \
61 $(GN_LIBINTL)
62
63
64gnunet_identity_SOURCES = \
65 gnunet-identity.c
66gnunet_identity_LDADD = \
67 libgnunetidentity.la \
68 $(top_builddir)/src/statistics/libgnunetstatistics.la \
69 $(top_builddir)/src/util/libgnunetutil.la \
70 $(GN_LIBINTL)
71
72check_PROGRAMS = \
73 test_identity
74
75check_SCRIPTS = \
76 test_identity_messages.sh
77
78if ENABLE_TEST_RUN
79AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME;
80TESTS = $(check_PROGRAMS) $(check_SCRIPTS)
81endif
82
83
84test_identity_SOURCES = \
85 test_identity.c
86test_identity_LDADD = \
87 libgnunetidentity.la \
88 $(top_builddir)/src/testing/libgnunettesting.la \
89 $(top_builddir)/src/util/libgnunetutil.la
90
91EXTRA_DIST = \
92 test_identity.conf \
93 test_identity_messages.sh
94
95