aboutsummaryrefslogtreecommitdiff
path: root/src/identity/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/identity/meson.build')
-rw-r--r--src/identity/meson.build24
1 files changed, 24 insertions, 0 deletions
diff --git a/src/identity/meson.build b/src/identity/meson.build
new file mode 100644
index 000000000..7153fff7f
--- /dev/null
+++ b/src/identity/meson.build
@@ -0,0 +1,24 @@
1libgnunetidentity_src = ['identity_api.c',
2 'identity_api_lookup.c',
3 'identity_api_suffix_lookup.c']
4
5gnunetserviceidentity_src = ['gnunet-service-identity.c']
6
7
8if gnunet_monolith == false
9 libgnunetidentity = library('gnunetidentity',
10 libgnunetidentity_src,
11 dependencies: [libgnunetutil_dep, sodium_dep],
12 include_directories: [incdir, configuration_inc])
13 libgnunetidentity_dep = declare_dependency(link_with : libgnunetidentity)
14 executable ('gnunet-service-identity',
15 gnunetserviceidentity_src,
16 dependencies: [libgnunetidentity_dep,
17 libgnunetutil_dep,
18 libgnunetstatistics_dep],
19 include_directories: [incdir, configuration_inc])
20else
21 foreach p : libgnunetidentity_src + gnunetserviceidentity_src
22 gnunet_src += 'identity/' + p
23 endforeach
24endif