aboutsummaryrefslogtreecommitdiff
path: root/src/lib/curl/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/lib/curl/Makefile.am')
-rw-r--r--src/lib/curl/Makefile.am38
1 files changed, 38 insertions, 0 deletions
diff --git a/src/lib/curl/Makefile.am b/src/lib/curl/Makefile.am
new file mode 100644
index 000000000..78eae4b97
--- /dev/null
+++ b/src/lib/curl/Makefile.am
@@ -0,0 +1,38 @@
1# This Makefile.am is in the public domain
2AM_CPPFLAGS = -I$(top_srcdir)/src/include
3
4if USE_COVERAGE
5 AM_CFLAGS = --coverage -O0
6 XLIB = -lgcov
7endif
8
9lib_LTLIBRARIES = \
10 libgnunetcurl.la
11
12libgnunetcurl_la_LDFLAGS = \
13 $(GN_LIBINTL) \
14 -version-info 0:0:0 \
15 -no-undefined
16libgnunetcurl_la_SOURCES = \
17 curl.c \
18 curl_reschedule.c
19libgnunetcurl_la_LIBADD = \
20 $(top_builddir)/src/lib/util/libgnunetutil.la \
21 -ljansson \
22 @LIBCURL@ \
23 $(XLIB)
24libgnunetcurl_la_CPPFLAGS = \
25 @LIBCURL_CPPFLAGS@ $(AM_CPPFLAGS) $(MHD_CFLAGS)
26
27#check_PROGRAMS = \
28# test_curl
29
30#TESTS = \
31# $(check_PROGRAMS)
32
33#test_curl_SOURCES = \
34# test_curl.c
35#test_curl_LDADD = \
36# libgnunetcurl.la \
37# $(top_builddir)/src/lib/util/libgnunetutil.la \
38# -ljansson -lcurl