aboutsummaryrefslogtreecommitdiff
path: root/src/lib/gnsrecord/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/lib/gnsrecord/Makefile.am')
-rw-r--r--src/lib/gnsrecord/Makefile.am111
1 files changed, 111 insertions, 0 deletions
diff --git a/src/lib/gnsrecord/Makefile.am b/src/lib/gnsrecord/Makefile.am
new file mode 100644
index 000000000..ab79de900
--- /dev/null
+++ b/src/lib/gnsrecord/Makefile.am
@@ -0,0 +1,111 @@
1# This Makefile.am is in the public domain
2AM_CPPFLAGS = -I$(top_srcdir)/src/include ${MHD_CFLAGS}
3
4plugindir = $(libdir)/gnunet
5
6pkgcfgdir= $(pkgdatadir)/config.d/
7
8libexecdir= $(pkglibdir)/libexec/
9
10if USE_COVERAGE
11 AM_CFLAGS = --coverage -O0
12 XLIBS = -lgcov
13endif
14
15noinst_PROGRAMS = \
16 gnunet-gnsrecord-tvg
17
18
19check_PROGRAMS = \
20 test_gnsrecord_crypto \
21 test_gnsrecord_serialization \
22 test_gnsrecord_lsd0001testvectors \
23 test_gnsrecord_block_expiration \
24 perf_gnsrecord_crypto
25
26if ENABLE_TEST_RUN
27AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME;
28TESTS = \
29 $(check_PROGRAMS) \
30 $(check_SCRIPTS)
31endif
32
33lib_LTLIBRARIES = \
34 libgnunetgnsrecord.la \
35 libgnunetgnsrecordjson.la
36
37gnunet_gnsrecord_tvg_SOURCES = \
38 gnunet-gnsrecord-tvg.c \
39 gnsrecord_crypto.h
40gnunet_gnsrecord_tvg_LDADD = \
41 $(top_builddir)/src/lib/util/libgnunetutil.la \
42 libgnunetgnsrecord.la \
43 $(GN_LIBINTL)
44
45
46libgnunetgnsrecord_la_SOURCES = \
47 gnsrecord.c \
48 gnsrecord_serialization.c \
49 gnsrecord_crypto.c \
50 gnsrecord_pow.c \
51 gnsrecord_misc.c
52libgnunetgnsrecord_la_LIBADD = \
53 $(top_builddir)/src/lib/util/libgnunetutil.la \
54 $(LIBGCRYPT_LIBS) \
55 -lsodium \
56 $(GN_LIBINTL)
57libgnunetgnsrecord_la_LDFLAGS = \
58 $(GN_LIB_LDFLAGS) \
59 -version-info 0:0:0
60
61libgnunetgnsrecordjson_la_SOURCES = \
62 json_gnsrecord.c
63libgnunetgnsrecordjson_la_LIBADD = \
64 $(top_builddir)/src/lib/util/libgnunetutil.la \
65 libgnunetgnsrecord.la \
66 -ljansson \
67 $(GN_LIBINTL)
68libgnunetgnsrecordjson_la_LDFLAGS = \
69 $(GN_LIB_LDFLAGS) \
70 -version-info 0:0:0
71
72EXTRA_DIST = \
73 $(check_SCRIPTS)
74
75test_gnsrecord_lsd0001testvectors_SOURCES = \
76 test_gnsrecord_testvectors.c
77test_gnsrecord_lsd0001testvectors_LDADD = \
78 $(top_builddir)/src/service/testing/libgnunettesting.la \
79 libgnunetgnsrecord.la \
80 $(top_builddir)/src/lib/util/libgnunetutil.la
81
82
83test_gnsrecord_serialization_SOURCES = \
84 test_gnsrecord_serialization.c
85test_gnsrecord_serialization_LDADD = \
86 $(top_builddir)/src/service/testing/libgnunettesting.la \
87 libgnunetgnsrecord.la \
88 $(top_builddir)/src/lib/util/libgnunetutil.la
89
90test_gnsrecord_block_expiration_SOURCES = \
91 test_gnsrecord_block_expiration.c
92test_gnsrecord_block_expiration_LDADD = \
93 $(top_builddir)/src/service/testing/libgnunettesting.la \
94 libgnunetgnsrecord.la \
95 $(top_builddir)/src/lib/util/libgnunetutil.la
96
97
98test_gnsrecord_crypto_SOURCES = \
99 test_gnsrecord_crypto.c
100test_gnsrecord_crypto_LDADD = \
101 $(top_builddir)/src/service/testing/libgnunettesting.la \
102 libgnunetgnsrecord.la \
103 $(top_builddir)/src/lib/util/libgnunetutil.la
104
105
106perf_gnsrecord_crypto_SOURCES = \
107 perf_gnsrecord_crypto.c
108perf_gnsrecord_crypto_LDADD = \
109 $(top_builddir)/src/service/testing/libgnunettesting.la \
110 libgnunetgnsrecord.la \
111 $(top_builddir)/src/lib/util/libgnunetutil.la