aboutsummaryrefslogtreecommitdiff
path: root/src/lib/gnsrecord/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/lib/gnsrecord/meson.build')
-rw-r--r--src/lib/gnsrecord/meson.build55
1 files changed, 55 insertions, 0 deletions
diff --git a/src/lib/gnsrecord/meson.build b/src/lib/gnsrecord/meson.build
index a35d6b66e..40eff89c1 100644
--- a/src/lib/gnsrecord/meson.build
+++ b/src/lib/gnsrecord/meson.build
@@ -29,3 +29,58 @@ libgnunetgnsrecordjson = library('gnunetgnsrecordjson',
29 install: true, 29 install: true,
30 install_dir: get_option('libdir')) 30 install_dir: get_option('libdir'))
31libgnunetgnsrecordjson_dep = declare_dependency(link_with : libgnunetgnsrecordjson) 31libgnunetgnsrecordjson_dep = declare_dependency(link_with : libgnunetgnsrecordjson)
32
33testgnsrecrd_perf_crypto = executable ('perf_gnsrecord_crypto',
34 ['perf_gnsrecord_crypto.c'],
35 dependencies: [libgnunetutil_dep,
36 libgnunetgnsrecord_dep],
37 include_directories: [incdir, configuration_inc],
38 build_by_default: false,
39 install: false)
40testgnsrecrd_test_crypto = executable ('test_gnsrecord_crypto',
41 ['test_gnsrecord_crypto.c'],
42 dependencies: [libgnunetutil_dep,
43 libgnunetgnsrecord_dep],
44 include_directories: [incdir, configuration_inc],
45 build_by_default: false,
46 install: false)
47testgnsrecrd_test_serialization = executable ('test_gnsrecord_serialization',
48 ['test_gnsrecord_serialization.c'],
49 dependencies: [libgnunetutil_dep,
50 libgnunetgnsrecord_dep],
51 include_directories: [incdir, configuration_inc],
52 build_by_default: false,
53 install: false)
54testgnsrecrd_test_tvs = executable ('test_gnsrecord_testvectors',
55 ['test_gnsrecord_testvectors.c'],
56 dependencies: [libgnunetutil_dep,
57 libgnunetgnsrecord_dep],
58 include_directories: [incdir, configuration_inc],
59 build_by_default: false,
60 install: false)
61testgnsrecrd_test_exp = executable ('test_gnsrecord_block_expiration',
62 ['test_gnsrecord_block_expiration.c'],
63 dependencies: [libgnunetutil_dep,
64 libgnunetgnsrecord_dep],
65 include_directories: [incdir, configuration_inc],
66 build_by_default: false,
67 install: false)
68
69test('perf_gnsrecord_crypto', testgnsrecrd_perf_crypto,
70 workdir: meson.current_build_dir(),
71 suite: ['gnsrecord'])
72test('test_gnsrecord_crypto', testgnsrecrd_test_crypto,
73 workdir: meson.current_build_dir(),
74 suite: ['gnsrecord'])
75test('test_gnsrecord_serialization', testgnsrecrd_test_serialization,
76 workdir: meson.current_build_dir(),
77 suite: ['gnsrecord'])
78test('test_gnsrecord_block_expiration', testgnsrecrd_test_exp,
79 workdir: meson.current_build_dir(),
80 suite: ['gnsrecord'])
81test('test_gnsrecord_serialization', testgnsrecrd_test_serialization,
82 workdir: meson.current_build_dir(),
83 suite: ['gnsrecord'])
84test('test_gnsrecord_testvectors', testgnsrecrd_test_tvs,
85 workdir: meson.current_build_dir(),
86 suite: ['gnsrecord'])