aboutsummaryrefslogtreecommitdiff
path: root/src/lib/hello/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/lib/hello/Makefile.am')
-rw-r--r--src/lib/hello/Makefile.am24
1 files changed, 1 insertions, 23 deletions
diff --git a/src/lib/hello/Makefile.am b/src/lib/hello/Makefile.am
index cbc193a0a..c7b3e4a05 100644
--- a/src/lib/hello/Makefile.am
+++ b/src/lib/hello/Makefile.am
@@ -18,38 +18,16 @@ libgnunethello_la_LDFLAGS = \
18 -version-info 1:0:1 18 -version-info 1:0:1
19 19
20check_PROGRAMS = \ 20check_PROGRAMS = \
21 test_hello \ 21 test_hello-uri
22 test_hello-uri \
23 test_friend_hello \
24 test_hello-ng
25 22
26if ENABLE_TEST_RUN 23if ENABLE_TEST_RUN
27AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME; 24AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME;
28TESTS = $(check_PROGRAMS) 25TESTS = $(check_PROGRAMS)
29endif 26endif
30 27
31test_hello_SOURCES = \
32 test_hello.c
33test_hello_LDADD = \
34 libgnunethello.la \
35 $(top_builddir)/src/lib/util/libgnunetutil.la
36
37test_hello_ng_SOURCES = \
38 test_hello-ng.c
39test_hello_ng_LDADD = \
40 libgnunethello.la \
41 $(top_builddir)/src/lib/util/libgnunetutil.la
42
43test_hello_uri_SOURCES = \ 28test_hello_uri_SOURCES = \
44 test_hello-uri.c 29 test_hello-uri.c
45test_hello_uri_LDADD = \ 30test_hello_uri_LDADD = \
46 libgnunethello.la \ 31 libgnunethello.la \
47 $(top_builddir)/src/lib/util/libgnunetutil.la \ 32 $(top_builddir)/src/lib/util/libgnunetutil.la \
48 -lgcrypt 33 -lgcrypt
49
50
51test_friend_hello_SOURCES = \
52 test_friend_hello.c
53test_friend_hello_LDADD = \
54 libgnunethello.la \
55 $(top_builddir)/src/lib/util/libgnunetutil.la