aboutsummaryrefslogtreecommitdiff
path: root/src/lib/hello/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/lib/hello/Makefile.am')
-rw-r--r--src/lib/hello/Makefile.am33
1 files changed, 33 insertions, 0 deletions
diff --git a/src/lib/hello/Makefile.am b/src/lib/hello/Makefile.am
new file mode 100644
index 000000000..c7b3e4a05
--- /dev/null
+++ b/src/lib/hello/Makefile.am
@@ -0,0 +1,33 @@
1# This Makefile.am is in the public domain
2AM_CPPFLAGS = -I$(top_srcdir)/src/include
3
4if USE_COVERAGE
5 AM_CFLAGS = --coverage -O0
6 XLIB = -lgcov
7endif
8
9lib_LTLIBRARIES = libgnunethello.la
10
11libgnunethello_la_SOURCES = \
12 hello-uri.c
13libgnunethello_la_LIBADD = \
14 $(top_builddir)/src/lib/util/libgnunetutil.la $(XLIB) \
15 $(LTLIBINTL)
16libgnunethello_la_LDFLAGS = \
17 $(GN_LIB_LDFLAGS) \
18 -version-info 1:0:1
19
20check_PROGRAMS = \
21 test_hello-uri
22
23if ENABLE_TEST_RUN
24AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME;
25TESTS = $(check_PROGRAMS)
26endif
27
28test_hello_uri_SOURCES = \
29 test_hello-uri.c
30test_hello_uri_LDADD = \
31 libgnunethello.la \
32 $(top_builddir)/src/lib/util/libgnunetutil.la \
33 -lgcrypt