aboutsummaryrefslogtreecommitdiff
path: root/src/lib/hello/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/lib/hello/meson.build')
-rw-r--r--src/lib/hello/meson.build27
1 files changed, 27 insertions, 0 deletions
diff --git a/src/lib/hello/meson.build b/src/lib/hello/meson.build
new file mode 100644
index 000000000..caf70e4a7
--- /dev/null
+++ b/src/lib/hello/meson.build
@@ -0,0 +1,27 @@
1libgnunethello_src = ['hello-uri.c']
2
3libgnunethello = library('gnunethello',
4 libgnunethello_src,
5 soversion: '0',
6 version: '0.1.0',
7 dependencies: libgnunetutil_dep,
8 include_directories: [incdir, configuration_inc],
9 install: true,
10 install_dir: get_option('libdir'))
11libgnunethello_dep = declare_dependency(link_with : libgnunethello)
12pkg.generate(libgnunethello, url: 'https://www.gnunet.org',
13 description : 'Helper library for handling GNUnet HELLO messages')
14
15
16test_hello_uri = executable ('test_hello_uri',
17 ['test_hello-uri.c'],
18 dependencies: [libgnunethello_dep,
19 libgnunetutil_dep,
20 gcrypt_dep],
21 include_directories: [incdir, configuration_inc],
22 build_by_default: false,
23 install: false)
24
25test('test_hello_uri', test_hello_uri,
26 workdir: meson.current_build_dir(),
27 suite: ['hello'])