aboutsummaryrefslogtreecommitdiff
path: root/src/lib/json/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/lib/json/meson.build')
-rw-r--r--src/lib/json/meson.build25
1 files changed, 25 insertions, 0 deletions
diff --git a/src/lib/json/meson.build b/src/lib/json/meson.build
new file mode 100644
index 000000000..98385163e
--- /dev/null
+++ b/src/lib/json/meson.build
@@ -0,0 +1,25 @@
1libgnunetjson_src = ['json.c',
2 'json_generator.c',
3 'json_helper.c',
4 'json_mhd.c',
5 'json_pack.c']
6
7if get_option('monolith')
8 foreach p : libgnunetjson_src
9 gnunet_src += 'json/' + p
10 endforeach
11 subdir_done()
12endif
13
14libgnunetjson = library('gnunetjson',
15 libgnunetjson_src,
16 soversion: '0',
17 version: '0.0.0',
18 dependencies: [libgnunetutil_dep, json_dep, mhd_dep, zlib_dep],
19 include_directories: [incdir, configuration_inc],
20 install: true,
21 install_dir: get_option('libdir'))
22libgnunetjson_dep = declare_dependency(link_with : libgnunetjson)
23pkg.generate(libgnunetjson, url: 'https://www.gnunet.org',
24 description : 'Library for JSON de/serialization')
25