aboutsummaryrefslogtreecommitdiff
path: root/src/mesh/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/mesh/Makefile.am')
-rw-r--r--src/mesh/Makefile.am20
1 files changed, 18 insertions, 2 deletions
diff --git a/src/mesh/Makefile.am b/src/mesh/Makefile.am
index 7d9a4daf8..c0733cafd 100644
--- a/src/mesh/Makefile.am
+++ b/src/mesh/Makefile.am
@@ -20,14 +20,19 @@ plugindir = $(libdir)/gnunet
20 20
21AM_CLFAGS = -g 21AM_CLFAGS = -g
22 22
23if HAVE_EXPERIMENTAL
24 EXP_LIB = libgnunetmesh2.la
25 EXP_LIBEXEC = gnunet-service-mesh-new
26endif
27
23libexec_PROGRAMS = \ 28libexec_PROGRAMS = \
24 gnunet-service-mesh gnunet-service-mesh-new 29 gnunet-service-mesh $(EXP_LIBEXEC)
25 30
26bin_PROGRAMS = \ 31bin_PROGRAMS = \
27 gnunet-mesh 32 gnunet-mesh
28 33
29lib_LTLIBRARIES = \ 34lib_LTLIBRARIES = \
30 libgnunetmesh.la 35 libgnunetmesh.la $(EXP_LIB)
31 36
32plugin_LTLIBRARIES = \ 37plugin_LTLIBRARIES = \
33 libgnunet_plugin_block_mesh.la 38 libgnunet_plugin_block_mesh.la
@@ -53,6 +58,17 @@ libgnunetmesh_la_LDFLAGS = \
53 $(GN_LIB_LDFLAGS) $(WINFLAGS) \ 58 $(GN_LIB_LDFLAGS) $(WINFLAGS) \
54 -version-info 2:1:1 59 -version-info 2:1:1
55 60
61libgnunetmesh2_la_SOURCES = \
62 mesh2_api.c mesh_common.c
63libgnunetmesh2_la_LIBADD = \
64 $(top_builddir)/src/util/libgnunetutil.la \
65 $(XLIB) \
66 $(LTLIBINTL)
67libgnunetmesh2_la_LDFLAGS = \
68 $(GN_LIB_LDFLAGS) $(WINFLAGS) \
69 -version-info 2:2:1
70
71
56gnunet_service_mesh_SOURCES = \ 72gnunet_service_mesh_SOURCES = \
57 gnunet-service-mesh.c \ 73 gnunet-service-mesh.c \
58 mesh_tunnel_tree.c mesh_tunnel_tree.h \ 74 mesh_tunnel_tree.c mesh_tunnel_tree.h \