aboutsummaryrefslogtreecommitdiff
path: root/src/multicast/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/multicast/Makefile.am')
-rw-r--r--src/multicast/Makefile.am17
1 files changed, 11 insertions, 6 deletions
diff --git a/src/multicast/Makefile.am b/src/multicast/Makefile.am
index a680a9d5a..13212bca3 100644
--- a/src/multicast/Makefile.am
+++ b/src/multicast/Makefile.am
@@ -50,13 +50,13 @@ gnunet_service_multicast_LDADD = \
50 $(GN_LIBINTL) 50 $(GN_LIBINTL)
51 51
52check_PROGRAMS = \ 52check_PROGRAMS = \
53 test_multicast_multipeer 53 test_multicast \
54# test_multicast 54 test_multicast_multipeer_star \
55 test_multicast_multipeer_line
55# test_multicast_2peers 56# test_multicast_2peers
56 57
57if ENABLE_TEST_RUN 58if ENABLE_TEST_RUN
58AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@}; export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH; unset XDG_DATA_HOME; unset XDG_CONFIG_HOME; 59AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@}; export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH; unset XDG_DATA_HOME; unset XDG_CONFIG_HOME;
59#AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@}; export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH; unset XDG_DATA_HOME; unset XDG_CONFIG_HOME; export GNUNET_FORCE_LOG=';;;;INFO';
60TESTS = $(check_PROGRAMS) 60TESTS = $(check_PROGRAMS)
61endif 61endif
62 62
@@ -66,10 +66,15 @@ test_multicast_LDADD = \
66 libgnunetmulticast.la \ 66 libgnunetmulticast.la \
67 $(top_builddir)/src/testing/libgnunettesting.la \ 67 $(top_builddir)/src/testing/libgnunettesting.la \
68 $(top_builddir)/src/util/libgnunetutil.la 68 $(top_builddir)/src/util/libgnunetutil.la
69 69test_multicast_multipeer_star_SOURCES = \
70test_multicast_multipeer_SOURCES = \ 70 test_multicast_multipeer.c
71test_multicast_multipeer_star_LDADD = \
72 libgnunetmulticast.la \
73 $(top_builddir)/src/testbed/libgnunettestbed.la \
74 $(top_builddir)/src/util/libgnunetutil.la
75test_multicast_multipeer_line_SOURCES = \
71 test_multicast_multipeer.c 76 test_multicast_multipeer.c
72test_multicast_multipeer_LDADD = \ 77test_multicast_multipeer_line_LDADD = \
73 libgnunetmulticast.la \ 78 libgnunetmulticast.la \
74 $(top_builddir)/src/testbed/libgnunettestbed.la \ 79 $(top_builddir)/src/testbed/libgnunettestbed.la \
75 $(top_builddir)/src/util/libgnunetutil.la 80 $(top_builddir)/src/util/libgnunetutil.la