aboutsummaryrefslogtreecommitdiff
path: root/src/multicast/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/multicast/Makefile.am')
-rw-r--r--src/multicast/Makefile.am61
1 files changed, 61 insertions, 0 deletions
diff --git a/src/multicast/Makefile.am b/src/multicast/Makefile.am
new file mode 100644
index 000000000..e5bc04dfa
--- /dev/null
+++ b/src/multicast/Makefile.am
@@ -0,0 +1,61 @@
1INCLUDES = -I$(top_srcdir)/src/include
2
3pkgcfgdir= $(pkgdatadir)/config.d/
4
5libexecdir= $(pkglibdir)/libexec/
6
7pkgcfg_DATA = \
8 multicast.conf
9
10if MINGW
11 WINFLAGS = -Wl,--no-undefined -Wl,--export-all-symbols
12endif
13
14if USE_COVERAGE
15 AM_CFLAGS = -fprofile-arcs -ftest-coverage
16endif
17
18lib_LTLIBRARIES = libgnunetmulticast.la
19
20libgnunetmulticast_la_SOURCES = \
21 multicast_api.c
22# multicast.h
23libgnunetmulticast_la_LIBADD = \
24 $(top_builddir)/src/util/libgnunetutil.la \
25 $(GN_LIBINTL) $(XLIB)
26libgnunetmulticast_la_LDFLAGS = \
27 $(GN_LIB_LDFLAGS) $(WINFLAGS) \
28 -version-info 0:0:0
29
30
31bin_PROGRAMS = \
32 gnunet-multicast
33
34libexec_PROGRAMS = \
35 gnunet-service-multicast
36
37gnunet_multicast_SOURCES = \
38 gnunet-multicast.c
39gnunet_multicast_LDADD = \
40 $(top_builddir)/src/util/libgnunetutil.la \
41 $(GN_LIBINTL)
42
43gnunet_service_multicast_SOURCES = \
44 gnunet-service-multicast.c
45gnunet_service_multicast_LDADD = \
46 $(top_builddir)/src/util/libgnunetutil.la \
47 $(GN_LIBINTL)
48
49
50check_PROGRAMS = \
51 test_multicast_api
52
53if ENABLE_TEST_RUN
54TESTS = $(check_PROGRAMS)
55endif
56
57test_multicast_api_SOURCES = \
58 test_multicast_api.c
59test_multicast_api_LDADD = \
60 $(top_builddir)/src/util/libgnunetutil.la
61