aboutsummaryrefslogtreecommitdiff
path: root/src/namecache/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/namecache/meson.build')
-rw-r--r--src/namecache/meson.build73
1 files changed, 73 insertions, 0 deletions
diff --git a/src/namecache/meson.build b/src/namecache/meson.build
new file mode 100644
index 000000000..aa92454e6
--- /dev/null
+++ b/src/namecache/meson.build
@@ -0,0 +1,73 @@
1libgnunetnamecache_src = ['namecache_api.c']
2
3gnunetnamecache_src = ['gnunet-namecache.c']
4gnunetservicenamecache_src = ['gnunet-service-namecache.c']
5
6configure_file(input : 'namecache.conf.in',
7 output : 'namecache.conf',
8 configuration : cdata,
9 install: true,
10 install_dir: pkgcfgdir)
11
12
13if get_option('monolith')
14 foreach p : libgnunetnamecache_src + libgnunetpluginnamecache_sqlite_src + gnunetservicenamecache_src
15 gnunet_src += 'namecache/' + p
16 endforeach
17 subdir_done()
18endif
19
20libgnunetnamecache = library('gnunetnamecache',
21 libgnunetnamecache_src,
22 soversion: '0',
23 version: '0.0.0',
24 dependencies: [libgnunetutil_dep,
25 libgnunetgnsrecord_dep],
26 include_directories: [incdir, configuration_inc],
27 install: true,
28 install_dir: get_option('libdir'))
29libgnunetnamecache_dep = declare_dependency(link_with : libgnunetnamecache)
30pkg.generate(libgnunetnamecache, url: 'https://www.gnunet.org',
31 description : 'Provides API for storing GNS records to a cache')
32
33shared_module('gnunet_plugin_namecache_sqlite',
34 ['plugin_namecache_sqlite.c'],
35 dependencies: [libgnunetutil_dep,
36 libgnunetgnsrecord_dep,
37 sqlite_dep,
38 libgnunetsq_dep],
39 include_directories: [incdir, configuration_inc],
40 install: true,
41 install_dir: get_option('libdir')/'gnunet')
42
43if pq_dep.found()
44 shared_module('gnunet_plugin_namecache_postgres',
45 ['plugin_namecache_postgres.c'],
46 dependencies: [libgnunetutil_dep,
47 libgnunetgnsrecord_dep,
48 pq_dep,
49 libgnunetpq_dep],
50 include_directories: [incdir, configuration_inc],
51 install: true,
52 install_dir: get_option('libdir')/'gnunet')
53endif
54
55executable ('gnunet-namecache',
56 gnunetnamecache_src,
57 dependencies: [libgnunetnamecache_dep,
58 libgnunetutil_dep,
59 libgnunetgnsrecord_dep,
60 libgnunetidentity_dep],
61 include_directories: [incdir, configuration_inc],
62 install: true,
63 install_dir: get_option('bindir'))
64executable ('gnunet-service-namecache',
65 gnunetservicenamecache_src,
66 dependencies: [libgnunetnamecache_dep,
67 libgnunetutil_dep,
68 libgnunetgnsrecord_dep,
69 libgnunetstatistics_dep],
70 include_directories: [incdir, configuration_inc],
71 install: true,
72 install_dir: get_option('libdir')/'gnunet'/'libexec')
73